summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 10:44:51 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:58 -0500
commit9e906e8d3b7303e9f22eb57d18cc437f06727b75 (patch)
tree9ac522f0aca2f8974e9341923c667c84c401eb79
parenta0557f7ed7818854e222949904021976cd9e8647 (diff)
downloadguix-patches-9e906e8d3b7303e9f22eb57d18cc437f06727b75.tar
guix-patches-9e906e8d3b7303e9f22eb57d18cc437f06727b75.tar.gz
gnu: python-apispec: Do not set PYTHONPATH.
* gnu/packages/python-xyz.scm (python-apispec) {disable-prance-tests}: Remove phase. [phases]{check}: Do not set PYTHONPATH. Exclude the tests using the CLI of Pytest.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4ac1ab296d..cccee4b4e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16460,19 +16460,13 @@ complex datatypes to and from native Python datatypes.")
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'disable-prance-tests
- (lambda _
- ;; Disable validation tests since they require the
- ;; optional 'prance' library which is not yet in Guix.
- (substitute* "tests/test_ext_marshmallow_openapi.py"
- (("def test_openapi_tools_validate.*" all)
- (string-append "@pytest.mark.xfail\n" all)))))
(replace 'check
(lambda _
- (setenv "PYTHONPATH"
- (string-append "./build/lib:"
- (getenv "PYTHONPATH")))
- (invoke "pytest" "-vv"))))))
+ (invoke "pytest" "-vv"
+ ;; Disable validation tests since they require
+ ;; the optional 'prance' library which is not
+ ;; yet in Guix.
+ "-k" "not openapi_tools_validate"))))))
(propagated-inputs
`(("python-pyyaml" ,python-pyyaml)))
(native-inputs