summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 00:30:24 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:53 -0500
commit7f081f43ed027fcf00a5fe7ab516586c80ed1cec (patch)
tree5cae95dc4a2f2f5df057a9a483e9438bcc5bc08c
parent141a90ea2cf948a4eb25eab6d30b61b16045eaae (diff)
downloadguix-patches-7f081f43ed027fcf00a5fe7ab516586c80ed1cec.tar
guix-patches-7f081f43ed027fcf00a5fe7ab516586c80ed1cec.tar.gz
gnu: python-colorlog: Do not set PYTHONPATH.
* gnu/packages/python-xyz.scm (python-colorlog) [phases]{check}: Do not set PYTHONPATH.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 71809ddc98..a0b0034966 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -334,12 +334,7 @@ implementation for the Telegram Bot API.")
`(#:phases (modify-phases %standard-phases
(replace 'check
(lambda _
- ;; Extend PYTHONPATH so the built package will be found.
- (setenv "PYTHONPATH"
- (string-append (getcwd) "/build/lib:"
- (getenv "PYTHONPATH")))
- (invoke "pytest" "-p" "no:logging")
- #t)))))
+ (invoke "pytest" "-p" "no:logging"))))))
(home-page "https://github.com/borntyping/python-colorlog")
(synopsis "Log formatting with colors for python")
(description "The @code{colorlog.ColoredFormatter} is a formatter for use