summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 00:28:18 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:53 -0500
commit141a90ea2cf948a4eb25eab6d30b61b16045eaae (patch)
tree55ffe5ad09d796858eef49bd0310d1ea77a888a2
parente2b35aeda0c650c698717bdb8dc12bc2f7f4739e (diff)
downloadguix-patches-141a90ea2cf948a4eb25eab6d30b61b16045eaae.tar
guix-patches-141a90ea2cf948a4eb25eab6d30b61b16045eaae.tar.gz
gnu: python-typed-ast: Do not set PYTHONPATH.
* gnu/packages/python-xyz.scm (python-typed-ast) [arguments]: Remove the '#:modules' argument. [phases]{check}: Do not set PYTHONPATH.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5e4b477943..71809ddc98 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18082,24 +18082,11 @@ source bytes using the UTF-8 encoding and then rewrites Python 3.6 style
(file-name (git-file-name name version))))
(build-system python-build-system)
(arguments
- `(#:modules ((guix build utils)
- (guix build python-build-system)
- (ice-9 ftw)
- (srfi srfi-1)
- (srfi srfi-26))
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
- (let ((cwd (getcwd)))
- (setenv "PYTHONPATH"
- (string-append cwd "/build/"
- (find (cut string-prefix? "lib" <>)
- (scandir (string-append cwd "/build")))
- ":"
- (getenv "PYTHONPATH"))))
- (invoke "pytest")
- #t)))))
+ (invoke "pytest"))))))
(native-inputs `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/python/typed_ast")
(synopsis "Fork of Python @code{ast} modules with type comment support")