summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-01-14 20:09:19 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-14 21:29:51 +0100
commit6aa5d54a1c8679a45c9c2513eb973c46fe24ae87 (patch)
tree1d4ce745b4c3e8e5b3a45b66219995457ee6b3dd
parent4835fefe62c8396b1f46dccf5d3210312dc85cfb (diff)
downloadguix-patches-6aa5d54a1c8679a45c9c2513eb973c46fe24ae87.tar
guix-patches-6aa5d54a1c8679a45c9c2513eb973c46fe24ae87.tar.gz
gnu: Add python-pytest-pydocstyle.
* gnu/packages/python-check.scm (python-pytest-pydocstyle): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 6d8e3560d9..871afe575c 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -686,6 +686,31 @@ framework and makes it easy to undo any monkey patching. The fixtures are:
in Pytest.")
(license license:bsd-3)))
+(define-public python-pytest-pydocstyle
+ (package
+ (name "python-pytest-pydocstyle")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/henry0312/pytest-pydocstyle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0w6fivz4nb4b70wzmi5sk17qs9pd05rnh03fmch6v00r3dmfpk39"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; test requires the package itself
+ (propagated-inputs
+ (list python-pydocstyle
+ python-pytest)) ;apparently required
+ (home-page "https://github.com/henry0312/pytest-pydocstyle")
+ (synopsis "Pytest plugin to run @command{pydocstyle}")
+ (description "This package provides a Pytest plugin to run
+@command{pydocstyle}.")
+ (license license:expat)))
+
(define-public python-covdefaults
(package
(name "python-covdefaults")