summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuix Together <jgart@dismail.de>2021-12-18 15:16:36 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-14 22:14:56 +0100
commit564d4e1b3c2017bb90f61173ef5ae84e8fa7aa6c (patch)
tree24519effca78ee893fef91feb675ae7af0d69a9a
parent5d9d1d9a7d2f1bba6623eda0bab664ea9ecb21ce (diff)
downloadguix-patches-564d4e1b3c2017bb90f61173ef5ae84e8fa7aa6c.tar
guix-patches-564d4e1b3c2017bb90f61173ef5ae84e8fa7aa6c.tar.gz
gnu: Add myrddin.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add myrddin.scm. * gnu/packages/myrddin.scm: New file. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Jorge Acereda <jacereda@gmail.com> Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/myrddin.scm65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1614c789cf..2b7bb3961d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -414,6 +414,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/music.scm \
%D%/packages/musl.scm \
%D%/packages/mtools.scm \
+ %D%/packages/myrddin.scm \
%D%/packages/nano.scm \
%D%/packages/ncdu.scm \
%D%/packages/ncurses.scm \
diff --git a/gnu/packages/myrddin.scm b/gnu/packages/myrddin.scm
new file mode 100644
index 0000000000..897276f57d
--- /dev/null
+++ b/gnu/packages/myrddin.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Guix Together <jgart@dismail.de>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages myrddin)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages pkg-config)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public myrddin
+ (package
+ (name "myrddin")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/oridb/mc")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0acqqz74ypmjvi1yqz7g1ymyk3mmkzwqgmdd3s7s287bdy4a72gc"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "bootstrap" make-flags)
+ (apply invoke "make" make-flags))))))
+ (native-inputs
+ (list bison pkg-config))
+ (home-page "https://myrlang.org")
+ (synopsis "Compiler and tools for the Myrddin programming language")
+ (description
+ "Myrddin is a programming language. It features strong type checking,
+generics, type inference, closures, and traits. It aims for C like low level
+control. This combination makes Myrddin suitable for anything ranging from
+desktop applications, to embedded systems and potentially even kernel
+development.")
+ (license license:expat)))