summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 15:25:52 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:16 +0000
commit1d8bb73d3dbcb3c36e970e22236b0dc1f98aae84 (patch)
tree3d7d3d8a3de72d24a970bcf9ba7a901a9a737445
parent751e73dea1efe6631da65dcbd025b0dc4d17ffd7 (diff)
downloadguix-patches-1d8bb73d3dbcb3c36e970e22236b0dc1f98aae84.tar
guix-patches-1d8bb73d3dbcb3c36e970e22236b0dc1f98aae84.tar.gz
gnu: gnome-todo: Update to 40.1.
* gnu/packages/patches/gnome-todo-delete-esource-duplicate.patch: Remove it. * gnu/local.mk (DIST_PATCH_DATA): Update it. * gnu/packages/gnome.scm (gnome-todo): Update to 40.1. [source]: Fix the URL. [arguments]: Remove the 'wrap-gnome-todo phase and add a 'skip-gtk-update-icon-cache phase. Disable the tests. [native-inputs]: Switch from gtk+ to gtk. [inputs]: Add gtk, libadwaita and libportal.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm39
-rw-r--r--gnu/packages/patches/gnome-todo-delete-esource-duplicate.patch10
3 files changed, 18 insertions, 32 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2a80f36ab7..23893034d5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1161,7 +1161,6 @@ dist_patch_DATA = \
%D%/packages/patches/gnome-shell-disable-test.patch \
%D%/packages/patches/gnome-shell-CVE-2020-17489.patch \
%D%/packages/patches/gnome-settings-daemon-gc.patch \
- %D%/packages/patches/gnome-todo-delete-esource-duplicate.patch \
%D%/packages/patches/gnome-tweaks-search-paths.patch \
%D%/packages/patches/gnupg-default-pinentry.patch \
%D%/packages/patches/gnupg-1-build-with-gcc10.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 800ac415de..70fade1cbe 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9647,46 +9647,43 @@ desktop. It supports multiple calendars, month, week and year view.")
(define-public gnome-todo
(package
(name "gnome-todo")
- (version "3.28.1")
+ (version "40.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "08ygqbib72jlf9y0a16k54zz51sncpq2wa18wp81v46q8301ymy7"))
- (patches
- (search-patches "gnome-todo-delete-esource-duplicate.patch"))))
+ "1r1fb3zgjvkhx93by24j8cg1w1g3zvwr49vqkscjn261vqs44jq3"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t
- #:phases (modify-phases %standard-phases
- (add-after
- 'install 'wrap-gnome-todo
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (python-path (getenv "GUIX_PYTHONPATH")))
- (wrap-program (string-append out "/bin/gnome-todo")
- ;; XXX: gi plugins are broken.
- ;; See https://bugzilla.gnome.org/show_bug.cgi?id=787212
- ;; For plugins.
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("GUIX_PYTHONPATH" ":" prefix (,python-path))))
- #t)))))
+ `(#:glib-or-gtk? #t
+ ;; XXX: Some tests fail with the following error:
+ ;; Settings schema 'org.gnome.todo' is not installed.
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "build-aux/meson/meson_post_install.py"
+ (("gtk-update-icon-cache") "true")))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("gobject-introspection" ,gobject-introspection)
("glib:bin" ,glib "bin") ; For glib-compile-resources
- ("gtk+-bin" ,gtk+ "bin") ; For gtk-update-icon-cache
+ ("gtk-bin" ,gtk "bin") ; For gtk-update-icon-cache
("pkg-config" ,pkg-config)))
(inputs
`(("rest" ,rest) ; For Todoist plugin
+ ("gtk" ,gtk)
("json-glib" ,json-glib) ; For Todoist plugin
+ ("libadwaita" ,libadwaita)
("libedataserverui" ,evolution-data-server)
("libical" ,libical)
("libpeas" ,libpeas)
+ ("libportal" ,libportal)
("python-pygobject" ,python-pygobject)
("evolution-data-server" ,evolution-data-server)
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
diff --git a/gnu/packages/patches/gnome-todo-delete-esource-duplicate.patch b/gnu/packages/patches/gnome-todo-delete-esource-duplicate.patch
deleted file mode 100644
index c680e86495..0000000000
--- a/gnu/packages/patches/gnome-todo-delete-esource-duplicate.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-From: Emmanuele Bassi <ebassi@gnome.org>
-
-See also: https://gitlab.gnome.org/GNOME/gnome-todo/commit/6cdabc4dd0c6c804a093b94c269461ce376fed4f
---- gnome-todo-3.28.1/plugins/eds/gtd-eds-autoptr.h.orig 2020-05-06 14:20:49.589902539 +0200
-+++ gnome-todo-3.28.1/plugins/eds/gtd-eds-autoptr.h 2020-05-06 14:20:54.593919721 +0200
-@@ -25,4 +25,3 @@
- G_DEFINE_AUTOPTR_CLEANUP_FUNC (ECalComponent, g_object_unref);
- G_DEFINE_AUTOPTR_CLEANUP_FUNC (ECalComponentId, e_cal_component_free_id);
- G_DEFINE_AUTOPTR_CLEANUP_FUNC (ECalClient, g_object_unref);
--G_DEFINE_AUTOPTR_CLEANUP_FUNC (ESource, g_object_unref);