summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-19 06:00:07 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-14 10:13:55 +0100
commita916093be21c1416f6b29a92669de6b527f486fa (patch)
tree3b40b970c20e690698f76994adf02318cb3d4266
parent8255e899b1e83d8cfd723741ce223f3806169997 (diff)
downloadguix-patches-a916093be21c1416f6b29a92669de6b527f486fa.tar
guix-patches-a916093be21c1416f6b29a92669de6b527f486fa.tar.gz
gnu: Add python-ipython-sql.
* gnu/packages/python-xyz.scm (python-ipython-sql): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0091165d37..ce53d486be 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8483,6 +8483,41 @@ profile, launches a cluster and returns a view. On program exit it shuts the
cluster down and deletes the throwaway profile.")
(license license:expat)))
+(define-public python-ipython-sql
+ (package
+ (name "python-ipython-sql")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ipython-sql" version))
+ (sha256
+ (base32 "0v74ayc6vw98f4jljmwy45qpqbcbhlrb4g1qdyypq9sppxcqx21y"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ ;; The "NEWS.rst" file is missing from the PyPI distribution.
+ ;; (see: https://github.com/catherinedevlin/ipython-sql/issues/164)
+ (substitute* "setup.py"
+ (("NEWS = [^\n]*") "")
+ (("long_description=README \\+ '\\\\n\\\\n' \\+ NEWS,")
+ "long_description=README,")))))))
+ (propagated-inputs
+ (list python-ipython
+ python-ipython-genutils
+ python-prettytable
+ python-six
+ python-sqlalchemy
+ python-sqlparse))
+ (home-page "https://github.com/catherinedevlin/ipython-sql")
+ (synopsis "RDBMS access via IPython")
+ (description "This library connects to a database, using SQLAlchemy URL
+connect strings, then issue SQL commands within IPython or IPython Notebook.")
+ (license license:expat)))
+
(define-public python-traitlets
(package
(name "python-traitlets")