summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Lerique <sl@eauchat.org>2021-10-15 11:40:20 +0900
committerLars-Dominik Braun <lars@6xq.net>2021-10-18 09:02:40 +0200
commit5f8b2bcff27df640457968ef1ecbfbf7f05bc9a7 (patch)
tree3d151f79fd3785976d91041a21c12bd94e75476c
parent51bd29f3c842731cc80bd4e7fefe0c9dd098a2e9 (diff)
downloadguix-patches-5f8b2bcff27df640457968ef1ecbfbf7f05bc9a7.tar
guix-patches-5f8b2bcff27df640457968ef1ecbfbf7f05bc9a7.tar.gz
gnu: python-h2: Update to 4.1.0.
* gnu/packages/python-web.scm (python-h2): Update to 4.1.0. [native-inputs]: Add python-hypothesis-6.23. [arguments]: Invoke pytest through `python -m` so it finds the newer python-hypothesis-6.23. [home-page]: Update to current url. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 11bb834ef9..f3f7afd80c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -934,13 +934,13 @@ and that could be anything you want.")
(define-public python-h2
(package
(name "python-h2")
- (version "3.2.0")
+ (version "4.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h2" version))
(sha256
- (base32 "051gg30aca26rdxsmr9svwqm06pdz9bv21ch4n0lgi7jsvml2pw7"))))
+ (base32 "1fraip114fm1ha5w37pdc0sk8dn9pb0ck267zrwwpap7zc4clfm8"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -949,13 +949,14 @@ and that could be anything you want.")
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "test")))))))
+ (invoke "python" "-m" "pytest" "-vv" "test")))))))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-hypothesis" ,python-hypothesis-6.23)
+ ("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-hpack" ,python-hpack)
("python-hyperframe" ,python-hyperframe)))
- (home-page "https://github.com/python-hyper/hyper-h2")
+ (home-page "https://github.com/python-hyper/h2")
(synopsis "HTTP/2 State-Machine based protocol implementation")
(description
"This module contains a pure-Python implementation of a HTTP/2 protocol