summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-16 11:01:38 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-18 09:02:42 +0200
commit42f13265355c60a5e3c0420b80ae4dad9074d0b4 (patch)
tree1cd696c8936c4e4e1ad2bd7dbd7e0fb0e51dda67
parent7caaebc50d799a5df1e8a56bf9394f4024caf459 (diff)
downloadguix-patches-42f13265355c60a5e3c0420b80ae4dad9074d0b4.tar
guix-patches-42f13265355c60a5e3c0420b80ae4dad9074d0b4.tar.gz
gnu: Add python-fields.
* gnu/packages/python-xyz.scm (python-fields): New variable.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0070e4c541..fd4eef5d9c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27565,3 +27565,19 @@ and powerful way to handle real-world data, featuring:
"This package provides the @code{python-box} Python module.
It implements advanced Python dictionaries with dot notation access.")
(license license:expat)))
+
+(define-public python-fields
+ (package
+ (name "python-fields")
+ (version "5.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fields" version))
+ (sha256
+ (base32 "09sppvhhkhkv9zc9g994m53z15v92csxwcf42ggkaknlv01smm1i"))))
+ (build-system python-build-system)
+ (home-page "https://python-fields.readthedocs.io/")
+ (synopsis "Python container class boilerplate killer")
+ (description "Avoid repetetive boilerplate code in Python classes.")
+ (license license:bsd-3)))