summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 00:30:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 00:32:37 +0100
commita3318b4edead56f4c15cf7b879c208260bb9d5c0 (patch)
tree29111ef1b52a87dab4427d782c9b6d323b343b72
parent8c6fb6820390e67a8efa7e6caccb989275f0d7fb (diff)
downloadguix-patches-a3318b4edead56f4c15cf7b879c208260bb9d5c0.tar
guix-patches-a3318b4edead56f4c15cf7b879c208260bb9d5c0.tar.gz
gnu: go-github-com-syndtr-goleveldb-leveldb: Use go-1.21.
* gnu/packages/golang.scm (go-github-com-syndtr-goleveldb-leveldb) [arguments] <#:go>: Swap to go-1.21. Change-Id: I6ecbfb8d2cbf29dc177536345fb1caa5001f35df
-rw-r--r--gnu/packages/golang.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5b473810cd..64b79564e6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5440,11 +5440,14 @@ golang's database/sql package.")
"042k0gbzs5waqpxmd7nv5h93mlva861s66c3s9gfg1fym5dx4vmd"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/syndtr/goleveldb/leveldb"
- #:unpack-path "github.com/syndtr/goleveldb"))
- (propagated-inputs (list go-github-com-onsi-gomega
- go-github-com-onsi-ginkgo
- go-github-com-golang-snappy))
+ (list
+ #:go go-1.21
+ #:import-path "github.com/syndtr/goleveldb/leveldb"
+ #:unpack-path "github.com/syndtr/goleveldb"))
+ (propagated-inputs
+ (list go-github-com-onsi-gomega
+ go-github-com-onsi-ginkgo
+ go-github-com-golang-snappy))
(home-page "https://github.com/syndtr/goleveldb")
(synopsis "LevelDB implementation in Go")
(description