summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-11 12:17:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 21:26:39 +0000
commit73867181830f5cb8d885a5404147ef675b1db707 (patch)
treeb42477f1b64d9dccc55d5ae42708d0bc36535a97
parent3463158205a0caff4656a5bc796675c93bd89d27 (diff)
downloadguix-patches-73867181830f5cb8d885a5404147ef675b1db707.tar
guix-patches-73867181830f5cb8d885a5404147ef675b1db707.tar.gz
gnu: go-github-com-oneofone-xxhash: Remove benchmarks.
* gnu/packages/golang.scm (go-github-com-oneofone-xxhash): Remove benchmarks. [arguments] <#:phases>: Add remove-benchmarks phase. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I68db9ff67e5d48e932e01509c26e9ce545cda5e6
-rw-r--r--gnu/packages/golang.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 053970b8ac..17db9dd9b9 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9468,7 +9468,13 @@ back.")
"0f98qk83l2fhpclvrgyxsa9b8m4pipf11fah85bnjl01wy4lvybw"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/OneOfOne/xxhash"))
+ (list
+ #:import-path "github.com/OneOfOne/xxhash"
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-benchmarks
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/benchmarks")))))))
(home-page "https://github.com/OneOfOne/xxhash")
(synopsis "Go implementation of xxHash")
(description "This is a native Go implementation of the