summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-12-27 22:29:37 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-12-28 10:21:55 +0100
commit53f51a908bf80739d60a99c74ffbfc1242db6c11 (patch)
treeb491db76e7da76ef41342ef2cbb84b7d1c898809
parenteb5554794e1e51a1da82de407d914c2bdfa8ba7e (diff)
downloadguix-patches-53f51a908bf80739d60a99c74ffbfc1242db6c11.tar
guix-patches-53f51a908bf80739d60a99c74ffbfc1242db6c11.tar.gz
gnu: Add python-pytest-cookies.
* gnu/packages/python-check.scm (python-pytest-cookies): New variable. Change-Id: I0b085d345bf1bce5fc9c03315da06954cf2125cb Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-check.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index ea74472270..f02ca10298 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -583,6 +583,38 @@ data arrays produced during tests, in particular in cases where the arrays
are too large to conveniently hard-code them in the tests.")
(license license:bsd-3)))
+(define-public python-pytest-cookies
+ (package
+ (name "python-pytest-cookies")
+ (version "0.7.0")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hackebrot/pytest-cookies")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1x7ny6mx1siy9law1cv1i63nvv9ds2g1dlagm40l8qymxry43mjn"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-cookiecutter))
+ (home-page "https://github.com/hackebrot/pytest-cookies")
+ (synopsis "Pytest plugin for Cookiecutter templates")
+ (description
+ "This Pytest plugin adds a @code{cookies} fixture, which is a
+wrapper for the Cookiecutter API. This fixture helps you verify that
+your template is working as expected and takes care of cleaning up after
+running the tests.")
+ (license license:expat)))
+
(define-public python-pytest-doctestplus
(package
(name "python-pytest-doctestplus")