summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-12-29 11:20:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-12-29 13:26:47 +0100
commit4d8b93e865ba71d2baa606d11529c3ecb5f14aea (patch)
tree7fed9f80cfbf88593f983c647aa0d3c53a6258a4
parentf90d6adec787187f7929159e3327c73245d3bbe3 (diff)
downloadguix-patches-4d8b93e865ba71d2baa606d11529c3ecb5f14aea.tar
guix-patches-4d8b93e865ba71d2baa606d11529c3ecb5f14aea.tar.gz
gnu: Add python-pymemcache.
* gnu/packages/python-xyz.scm (python-pymemcache): New variable. Change-Id: I2141c79d01d8a59e9cd4ee2fbef608ba882ffaa9
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee689809a3..bac82b4893 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20288,6 +20288,31 @@ etc.")
support.")
(license license:bsd-3)))
+(define-public python-pymemcache
+ (package
+ (name "python-pymemcache")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pymemcache" version))
+ (sha256
+ (base32 "157z9blr8pjg9x84jph5hm0z2l6yaq6n421jcf1hzqn1pg8rpgr7"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; We don't have the zstd module.
+ (list
+ #:test-flags
+ '(list "--ignore=pymemcache/test/test_compression.py")))
+ (native-inputs
+ (list python-faker python-pytest python-pytest-cov))
+ (home-page "https://github.com/pinterest/pymemcache")
+ (synopsis "Comprehensive, fast, pure Python memcached client")
+ (description
+ "This package provides a comprehensive, fast, pure Python memcached
+client.")
+ (license license:asl2.0)))
+
(define-public python-pymodbus
(package
(name "python-pymodbus")