summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgios Athanasiou <yorgath@gmail.com>2024-01-07 13:27:07 +0200
committerMathieu Othacehe <othacehe@gnu.org>2024-01-07 19:29:23 +0100
commit9c634835e5d4418095257dee71eb0bfaaddffa05 (patch)
tree83573a6871961af7feb1911a2efadea844d7882c
parent224499f2d466b1a3f3a45e44a709a983185b69ca (diff)
downloadguix-patches-9c634835e5d4418095257dee71eb0bfaaddffa05.tar
guix-patches-9c634835e5d4418095257dee71eb0bfaaddffa05.tar.gz
gnu: Add guile-yamlpp.
* gnu/packages/guile-xyz.scm (guile-yamlpp): New variable. Change-Id: I54694eeea17e414df4d7778a2e119f3f995c20e4 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 75e3754046..9dc1176797 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1839,6 +1839,33 @@ written in pure Scheme by using Guile's foreign function interface.")
library}.")
(license license:gpl3+)))
+(define-public guile-yamlpp
+ (package
+ (name "guile-yamlpp")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/yorgath/guile-yamlpp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14mlqi7hw7pi9scwk1g432issnqcn185pd8na2plijxq55cy0iq7"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool pkg-config))
+ (inputs (list guile-3.0 yaml-cpp))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GUILE_EXTENSIONS_PATH")
+ (files (list "lib/guile/3.0")))))
+ (home-page "https://gitlab.com/yorgath/guile-yamlpp")
+ (synopsis "Guile YAML reader/writer based on @code{yaml-cpp}")
+ (description
+ "A module for GNU Guile to read and write YAML files. It works using
+bindings to the @code{yaml-cpp} C++ library.")
+ (license license:gpl3+)))
+
(define-public guile-dbi
(package
(name "guile-dbi")