summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-18 00:38:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-09 22:10:10 -0500
commitc235957534cf2f42e38c876318a64b5c784ebd8b (patch)
treec6f9da735e5abe0931be597a264616bb3abc8183
parent8fefe1b345f866cfcd7ecac9e4627039be10a856 (diff)
downloadguix-patches-c235957534cf2f42e38c876318a64b5c784ebd8b.tar
guix-patches-c235957534cf2f42e38c876318a64b5c784ebd8b.tar.gz
gnu: libnatpmp: Use gexps and simplify.
* gnu/packages/networking.scm (libnatpmp) [arguments]: Use gexps. Use gexp variables and cc-for-target in make flags.
-rw-r--r--gnu/packages/networking.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cc6f1a1e04..938e27fd79 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1427,19 +1427,13 @@ files contain direct mappings of the abstractions provided by the ØMQ C API.")
"0w7wvf4yi8qv659dg9d3ndqvh3bqhgm21gd135spwhq6hhnfv106"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'check)) ; no tests
- #:make-flags
- (let* ((target ,(%current-target-system))
- (gcc (if target
- (string-append target "-gcc")
- "gcc")))
- (list
- (string-append "CC=" gcc)
- (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
- (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")))))
+ (list #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)) ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "INSTALLPREFIX=" #$output)
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))))
(home-page "http://miniupnp.free.fr/libnatpmp.html")
(synopsis "C library implementing NAT-PMP")
(description