summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-11-18 22:54:35 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-09 10:19:44 +0100
commita1a645337a76cf5fb55d20ee694fcb6a52fcf11b (patch)
tree2dd6823038e1ecb084a33925825e7f1fd8b8ab09
parent7d25add8dd9175bec9f1b81703d7c0f752caa25b (diff)
downloadguix-patches-a1a645337a76cf5fb55d20ee694fcb6a52fcf11b.tar
guix-patches-a1a645337a76cf5fb55d20ee694fcb6a52fcf11b.tar.gz
gnu: Add python-ripser.
* gnu/packages/machine-learning.scm (python-ripser): New variable. Change-Id: I21b42e555a5017e68cf43a6eaa19d991db36723d Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/machine-learning.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 67a8041f72..1616738399 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -873,6 +873,34 @@ It currently houses implementations of
")
(license license:expat))) ; MIT License
+(define-public python-ripser
+ (package
+ (name "python-ripser")
+ (version "0.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ripser" version))
+ (sha256
+ (base32 "1575nwsn6b29z7w1mjk23ri83bxq2b4ld979hpgm174642a3x6vs"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-numpy python-persim python-scikit-learn
+ python-scipy))
+ (native-inputs (list python-cython python-pytest))
+ (home-page "https://ripser.scikit-tda.org")
+ (synopsis "Persistent homology library for Python")
+ (description
+ "This package implements a variety of persistent homology algorithms. It
+provides an interface for
+@itemize
+@item computing persistence cohomology of sparse and dense data sets
+@item visualizing persistence diagrams
+@item computing lowerstar filtrations on images
+@item computing representative cochains
+@end itemize
+")
+ (license license:expat))) ; MIT License
+
(define-public python-sacrebleu
(package
(name "python-sacrebleu")