summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-11-18 22:53:45 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-09 10:19:43 +0100
commit7d25add8dd9175bec9f1b81703d7c0f752caa25b (patch)
tree86f356482ebf6807bbdf614976af683d55430476
parente00314c4062c206d1fcabf533c681b53c59a359f (diff)
downloadguix-patches-7d25add8dd9175bec9f1b81703d7c0f752caa25b.tar
guix-patches-7d25add8dd9175bec9f1b81703d7c0f752caa25b.tar.gz
gnu: Add python-persim.
* gnu/packages/machine-learning.scm (python-persim): New variable. Change-Id: I914071a90b4555d7d1218ce83337d49298effb01 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/machine-learning.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index d852b0debe..67a8041f72 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -837,6 +837,42 @@ depend on language-specific pre- or post-processing.")
cardinality matching from a bipartite graph.")
(license license:gpl3))))
+(define-public python-persim
+ (package
+ (name "python-persim")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "persim" version))
+ (sha256
+ (base32 "0q8wfakx8q4h3ryvw8cba0v6z7xn9139qkrzs3mi1ggyzacnx9d7"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-deprecated
+ python-hopcroftkarp
+ python-joblib
+ python-matplotlib
+ python-numpy
+ python-scikit-learn
+ python-scipy))
+ (native-inputs (list python-pytest python-pytest-cov))
+ (home-page "https://persim.scikit-tda.org")
+ (synopsis "Tools for analyzing persistence diagrams in Python")
+ (description
+ "This package includes a variety of tools used to analyze persistence diagrams.
+It currently houses implementations of
+@itemize
+@item Persistence images
+@item Persistence landscapes
+@item Bottleneck distance
+@item Modified Gromov–Hausdorff distance
+@item Sliced Wasserstein kernel
+@item Heat kernel
+@item Diagram plotting
+@end itemize
+")
+ (license license:expat))) ; MIT License
+
(define-public python-sacrebleu
(package
(name "python-sacrebleu")