summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-25 11:36:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-25 11:36:20 +0200
commitbdab356332e391e09d0feafe0fcac9c52388a07d (patch)
tree5f2911b5325a76843bb106a7081575b8c9218a52
parentf7bca895b91c4e12324f34311e312ace2835e0df (diff)
downloadguix-patches-bdab356332e391e09d0feafe0fcac9c52388a07d.tar
guix-patches-bdab356332e391e09d0feafe0fcac9c52388a07d.tar.gz
gnu: curl: Fix test suite on arm platforms.
* gnu/packages/curl.scm (curl)[arguments]: Adjust the flags in the custom 'check phase to skip a test instead of ignoring the test result. Change-Id: Ib2098137b04766988507d2f86832871150cd0af7
-rw-r--r--gnu/packages/curl.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 0bf6d996e6..f73aed679d 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -136,9 +136,9 @@
(target-arm32?)
(target-aarch64?))
;; protocol FAIL
- (string-append "TFLAGS=\"~1474 "
- "~1477 "
- job-count "\"")
+ (string-append "TFLAGS=~1474 "
+ "!1477 "
+ job-count)
(string-append "TFLAGS=\"~1477 "
job-count "\"")))))
;; The top-level "make check" does "make -C tests quiet-test", which