summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Cottam <tristan@cott.am>2023-11-18 12:31:13 +0100
committerLudovic Courtès <ludo@gnu.org>2024-01-07 16:56:00 +0100
commitb6106e8fff83c1fdf1d46527813b7b1f2fc90801 (patch)
treed55448b60c4fa8c83defc53ab63d3c80f72ba104
parent51d25c771cfb7e26f5bd0d675893f68a8cbb92dc (diff)
downloadguix-patches-b6106e8fff83c1fdf1d46527813b7b1f2fc90801.tar
guix-patches-b6106e8fff83c1fdf1d46527813b7b1f2fc90801.tar.gz
gnu: Add emacs-adwaita-dark-theme
* gnu/packages/emacs-xyz.scm (emacs-adwaita-dark-theme): New variable. Change-Id: Id6e6d0d6aa27e7c1cc6ec0fc11c3a5f09231d751 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 64cc7e163d..99c16f382d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2017,6 +2017,27 @@ Apprentice and Sourcerer.")
theme but now takes more inspiration from the Nano theme.")
(license license:gpl3+)))
+(define-public emacs-adwaita-dark-theme
+ ;; Version 1.1.1 isn't tagged upstream.
+ (package
+ (name "emacs-adwaita-dark-theme")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/jessieh/adwaita-dark-theme")
+ (commit "057c39313341907b35c68d2179226886a0c276fd")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g7hyg2hfvn24gaw4lca4g8lw10q2wg9nfrgl7pfdggz202m027c"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/jessieh/adwaita-dark-theme")
+ (synopsis "Adwaita-inspired dark color scheme for Emacs")
+ (description
+ "This package provides an Adwaita-inspired dark color scheme for Emacs.")
+ (license license:gpl2+)))
+
(define-public emacs-treepy
(package
(name "emacs-treepy")