summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2024-01-06 11:20:51 +0900
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-01-07 10:07:23 +0100
commit33e6572beea174a087809c02bd33ead97e14bf33 (patch)
treeb96789a15bd8e83df6bb4a50d61d9b87bdfab2b5
parenta8f2c03a60e7f3fa93d537dd81c98b2f11ceab81 (diff)
downloadguix-patches-33e6572beea174a087809c02bd33ead97e14bf33.tar
guix-patches-33e6572beea174a087809c02bd33ead97e14bf33.tar.gz
gnu: taisei: Use new package style.
* gnu/packages/games.scm (taisei)[arguments]: Convert to list of G-Expressions. [license]: Reformat with guix style. Change-Id: I717a7e408f5ae274c5aafa0f3e20bb7bca377b3a Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/games.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6f4f8c14ac..c4284e54c4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -78,7 +78,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
@@ -3447,12 +3447,12 @@ a C library, so they can easily be integrated into other programs.")
(base32 "1g53fcyrlzmvlsb40pw90gaglysv6n1w42hk263iv61ibhdmzh6v"))))
(build-system meson-build-system)
(arguments
- `(#:build-type "release" ;comment out for bug-reporting (and cheats)
- #:configure-flags
- (list "-Dr_default=gles30"
- "-Dr_gles20=true"
- "-Dr_gles30=true"
- "-Dshader_transpiler=true")))
+ (list
+ #:build-type "release" ;comment out for bug-reporting (and cheats)
+ #:configure-flags #~(list "-Dr_default=gles30"
+ "-Dr_gles20=true"
+ "-Dr_gles30=true"
+ "-Dshader_transpiler=true")))
(native-inputs
(list pkg-config python python-docutils python-pygments))
(inputs
@@ -3475,14 +3475,15 @@ a C library, so they can easily be integrated into other programs.")
"The player controls a character (one of three: Good, Bad, and Dead),
dodges the missiles (lots of it cover the screen, but the character's hitbox
is very small), and shoot at the adversaries that keep appear on the screen.")
- (license (list ;;game
- license:expat
- ;;resources/00-taisei.pkgdir/bgm/
- ;;atlas/portraits/
- license:cc-by4.0
- ;;miscellaneous
- license:cc0
- license:public-domain))))
+ (license (list
+ ;; game
+ license:expat
+ ;; resources/00-taisei.pkgdir/bgm/
+ ;; atlas/portraits/
+ license:cc-by4.0
+ ;; miscellaneous
+ license:cc0
+ license:public-domain))))
(define-public cmatrix
(package