summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-05 14:56:22 +0000
committerEric Bavier <bavier@posteo.net>2023-11-18 19:56:30 -0600
commitd335e24920bfb90e38854c590647cf8e4b525292 (patch)
treedd073b7cd89b17df4620efa0f0f1adeea5cc7485
parent0cff3c49e17e1a1cc2bed6532ca672f19163bdc3 (diff)
downloadguix-patches-d335e24920bfb90e38854c590647cf8e4b525292.tar
guix-patches-d335e24920bfb90e38854c590647cf8e4b525292.tar.gz
gnu: elemental: Update package style.
* gnu/packages/maths.scm (elemental): Update package style, shift order of package fields. [arguments]: Use G-expressions. {phases}: Remove trailing #f from each lambda. Change-Id: Ib961eb99159e1206963041bd7014dca032a21441 Signed-off-by: Eric Bavier <bavier@posteo.net>
-rw-r--r--gnu/packages/maths.scm48
1 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0ed25834f6..34710fc65c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -7611,7 +7611,29 @@ symmetric matrices.")
(base32
"06xcs4ic60ndcf2hq19gr8yjwdsnphpcyhapab41rkw726z4lm7p"))))
(build-system cmake-build-system)
- (home-page "https://github.com/elemental/Elemental")
+ (arguments
+ (list
+ #:build-type "Release" ;default RelWithDebInfo not supported
+ #:configure-flags
+ #~(list "-DEL_DISABLE_PARMETIS:BOOL=YES"
+ "-DEL_AVOID_COMPLEX_MPI:BOOL=NO"
+ "-DEL_CACHE_WARNINGS:BOOL=YES"
+ "-DEL_TESTS:BOOL=YES"
+ "-DCMAKE_INSTALL_LIBDIR=lib"
+ "-DGFORTRAN_LIB=gfortran")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'mpi-setup
+ #$%openmpi-setup)
+ (add-before 'check 'setup-tests
+ (lambda _ ;; Parallelism is done at the MPI layer.
+ (setenv "OMP_NUM_THREADS" "1")))
+ (add-after 'install 'remove-tests
+ (lambda _
+ ;; Tests are installed, with no easy configuration
+ ;; switch to prevent this, so delete them.
+ (delete-file-recursively
+ (string-append #$output "/bin/test")))))))
(native-inputs
(list gfortran))
(inputs
@@ -7624,29 +7646,7 @@ symmetric matrices.")
openmpi
qd
openblas))
- (arguments
- `(#:build-type "Release" ;default RelWithDebInfo not supported
- #:configure-flags `("-DEL_DISABLE_PARMETIS:BOOL=YES"
- "-DEL_AVOID_COMPLEX_MPI:BOOL=NO"
- "-DEL_CACHE_WARNINGS:BOOL=YES"
- "-DEL_TESTS:BOOL=YES"
- "-DCMAKE_INSTALL_LIBDIR=lib"
- "-DGFORTRAN_LIB=gfortran")
- #:phases (modify-phases %standard-phases
- (add-before 'check 'mpi-setup
- ,%openmpi-setup)
- (add-before 'check 'setup-tests
- (lambda _
- ;; Parallelism is done at the MPI layer.
- (setenv "OMP_NUM_THREADS" "1")
- #t))
- (add-after 'install 'remove-tests
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Tests are installed, with no easy configuration
- ;; switch to prevent this, so delete them.
- (delete-file-recursively
- (string-append (assoc-ref outputs "out") "/bin"))
- #t)))))
+ (home-page "https://github.com/elemental/Elemental")
(synopsis "Dense and sparse-direct linear algebra and optimization")
(description "Elemental is a modern C++ library for distributed-memory
dense and sparse-direct linear algebra, conic optimization, and lattice