summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-17 12:16:13 +0000
committerEric Bavier <bavier@posteo.net>2023-11-18 19:56:32 -0600
commitba3a3aa311147afc4c1be941e79c557c73726a44 (patch)
tree09923e3dbb05226f81fd1f7b86fe29e25556685a
parent7a4c272619e1c0de9ab7aa76ddd59829087c391a (diff)
downloadguix-patches-ba3a3aa311147afc4c1be941e79c557c73726a44.tar
guix-patches-ba3a3aa311147afc4c1be941e79c557c73726a44.tar.gz
gnu: python-poliastro: Improve package style.
* gnu/package/astronomy.scm (python-poliastro): Improve package style. [arguments]: Swap to use {test-flags} and standard {check} phase. Change-Id: I0dde01af97adc883e8a3ce82a8448f4d10fdab64 Signed-off-by: Eric Bavier <bavier@posteo.net>
-rw-r--r--gnu/packages/astronomy.scm27
1 files changed, 11 insertions, 16 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index d12dccc208..f19f40a69d 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2118,27 +2118,22 @@ of astronomical sources.")
(build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
+ #~(list "-m" "not remote_data"
+ ;; TODO: Review failing tests later when any upstream
+ ;; suggestions are provided:
+ ;; https://github.com/poliastro/poliastro/issues/1618
+ "-k" (string-append "not test_czml_add_trajectory"
+ " and not test_czml_custom_packet"
+ " and not test_czml_ground_station"
+ " and not test_czml_groundtrack"
+ " and not test_czml_preamble"))
#:phases
#~(modify-phases %standard-phases
;; NOTE: Tests take about 7-10 minutes to pass.
(add-before 'check 'prepare-test-environment
(lambda _
- (setenv "HOME" "/tmp")
- ;; TODO: Review failing tests later when any upstream
- ;; suggestions are provided:
- ;; https://github.com/poliastro/poliastro/issues/1618
- (substitute* "tests/test_czml.py"
- (("def test_czml_add_trajectory") "def __off_test_czml_add_trajectory")
- (("def test_czml_custom_packet") "def __off_test_czml_custom_packet")
- (("def test_czml_ground_station") "def __off_test_czml_ground_station")
- (("def test_czml_groundtrack") "def __off_test_czml_groundtrack")
- (("def test_czml_preamble") "def __off_test_czml_preamble"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest"
- ;; Skip tests that need remote data.
- "-m" "not remote_data")))))))
+ (setenv "HOME" "/tmp"))))))
(native-inputs
(list python-coverage
python-hypothesis