summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-17 12:16:20 +0000
committerEric Bavier <bavier@posteo.net>2023-11-18 19:56:32 -0600
commitb7abea0fd6a146563830db1dc4ddd0cceb6fcf1c (patch)
tree7107d58f4f3a2190145c60afcb8dd79c180fff6d
parent1144680dab4aece86e21b6749ab19a4d2a3df23c (diff)
downloadguix-patches-b7abea0fd6a146563830db1dc4ddd0cceb6fcf1c.tar
guix-patches-b7abea0fd6a146563830db1dc4ddd0cceb6fcf1c.tar.gz
gnu: python-stsci-stimage: Enable tests.
* gnu/packages/astronomy.scm (python-stsci-stimage): Enable tests. [arguments]{phases}: Add custom 'check phase. [native-inputs]: Add python-waf and indent list. Change-Id: Ifceace1d89aff97e938c4fb95f33525477499949 Signed-off-by: Eric Bavier <bavier@posteo.net>
-rw-r--r--gnu/packages/astronomy.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bf419ae526..c063285b52 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2695,11 +2695,23 @@ task}.")
(build-system pyproject-build-system)
(arguments
(list
- ;; XXX: Fix failing tests. There are errors to load test files.
- #:tests? #f))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Test steps are taken from GitHub Actions.
+ ;; See https://github.com/spacetelescope/stsci.stimage/issues/27
+ (replace 'check
+ (lambda _
+ (copy-file (string-append
+ #$(this-package-native-input "python-waf") "/bin/waf")
+ "waf")
+ (invoke "python" "waf" "configure" "build" "do_tests"))))))
(propagated-inputs (list python-numpy))
- (native-inputs (list python-codecov python-pytest python-pytest-cov
- python-setuptools-scm))
+ (native-inputs
+ (list python-codecov
+ python-pytest
+ python-pytest-cov
+ python-setuptools-scm
+ python-waf))
(home-page "https://stscistimage.readthedocs.io/en/latest/")
(synopsis "STScI image processing")
(description "This package provides an astronomical Python package with