summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2023-11-11 19:19:16 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-15 18:29:38 +0100
commit416ae9ad8973ec8a4099914153f4d160b91ee77e (patch)
treeaa06cab0233323cab0a07bdab42b7549964e0cab
parent7c9e26484959a358946dc061e15104437961c08b (diff)
downloadguix-patches-416ae9ad8973ec8a4099914153f4d160b91ee77e.tar
guix-patches-416ae9ad8973ec8a4099914153f4d160b91ee77e.tar.gz
gnu: Add python-tdda.
* gnu/packages/python-science.scm (python-tdda): New variable. Change-Id: I456aa236b3348e5b990289d8a381c2d5276a12f1 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-science.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 4063797a30..949cd11929 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -349,6 +350,38 @@ implements several methods for sequential model-based optimization.
@code{skopt} aims to be accessible and easy to use in many contexts.")
(license license:bsd-3)))
+(define-public python-tdda
+ (package
+ (name "python-tdda")
+ (version "2.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "tdda" version))
+ (sha256
+ (base32 "1xs91s8b7cshjcqw88qsrjh10xly799k5rf2ycawqfz2mw8sy3br"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ (("pandas>=1.5.2")
+ "pandas"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "tdda" "test")))))))
+ (native-inputs (list python-numpy python-pandas))
+ (home-page "https://www.stochasticsolutions.com")
+ (synopsis "Test-driven data analysis library for Python")
+ (description
+ "The TDDA Python module provides command-line and Python API support
+for the overall process of data analysis, through tools that peform
+reference testing, constraint discovery for data, automatic inference
+of regular expressions from text data and automatic test generation.")
+ (license license:expat))) ; MIT License
+
(define-public python-trimesh
(package
(name "python-trimesh")