summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-11-16 20:49:05 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-20 20:41:56 +0100
commit93fd21717f4cbc4d416b354e6a77c7f8e3bdfe58 (patch)
tree86afd8a7e0243727a7c825d8aa2cff07da15a137
parent7bc6a2ef4d27195ebe1b968d1ae1d698aa40863d (diff)
downloadguix-patches-93fd21717f4cbc4d416b354e6a77c7f8e3bdfe58.tar
guix-patches-93fd21717f4cbc4d416b354e6a77c7f8e3bdfe58.tar.gz
gnu: gnome-builder: Update to 44.2.
* gnu/packages/gnome.scm (gnome-builder): Update to 44.2. [#:configure-flags]: Add -Ddocs=true. [#:phases]<patch-meson>: Also disable gtk-update-icon-cache in meson.build. Disable test-shortcuts. <set-home>: New phase. <pre-check>: Only enable it when tests? is true. <wrap-typelib>: New phase. [inputs]: Add d-spy, editorconfig-core-c, libdex, libpanel. Replace gtk+ with gtk, libhandy with libadwaita, libsoup-minimal-2 with libsoup, sysprof-3.44 with sysprof, vte with vte-with-gtk-4 and webkitgtk-with-libsoup2 with webkitgtk. Remove glade3. [propagated-inputs]: Replace gtksourceview-4 with gtksourceview. [native-inputs]: Add gi-docgen. Change-Id: I3ac149b76813e28d523fd67050efb0744771a296 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/gnome.scm61
1 files changed, 42 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index bc3f6359b5..194a443484 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13079,7 +13079,7 @@ libraries. Applications do not need to be recompiled--or even restarted.")
(define-public gnome-builder
(package
(name "gnome-builder")
- (version "42.1")
+ (version "44.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -13087,57 +13087,80 @@ libraries. Applications do not need to be recompiled--or even restarted.")
name "-" version ".tar.xz"))
(sha256
(base32
- "02k78mamp1yf9y6wixd864hdf9saw83wdw01f80lhnw60avm2kax"))))
+ "1c192xzjv5hsbp1p3wil595810k49kgmf5a7lwf260izip3qk9ng"))))
(build-system meson-build-system)
(arguments
(list
#:glib-or-gtk? #t ;To wrap binaries and compile schemas
- #:configure-flags #~(list "-Dnetwork_tests=false")
+ #:configure-flags #~(list "-Dnetwork_tests=false" "-Ddocs=true")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-meson
(lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))
(substitute* "build-aux/meson/post_install.py"
+ ;; The post_install script does not seem to respect the
+ ;; previous setting regarding gtk-update-icon-cache.
(("gtk-update-icon-cache") "true")
(("update-desktop-database") "true"))
- (substitute* "src/libide/meson.build"
- (("/usr/lib")
- (string-append #$(this-package-input "python-pygobject")
- "/lib")))))
- (add-before 'check 'pre-check
+ ;; This test is failing for unclear reasons.
+ (substitute* "src/tests/meson.build"
+ (("test\\('test-shortcuts'")
+ "# test('test-shortcuts'"))))
+ (add-before 'build 'set-home
(lambda _
- (system "Xvfb :1 &")
- (setenv "DISPLAY" ":1"))))))
+ ;; Required for documentation.
+ (setenv "HOME" (getcwd))))
+ (add-before 'check 'pre-check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1"))))
+ (add-after 'glib-or-gtk-wrap 'wrap-typelib
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/gnome-builder")
+ `("GI_TYPELIB_PATH" suffix (,(getenv "GI_TYPELIB_PATH")))))))))
(inputs
- (list cmark
+ (list bash-minimal ;for wrap-program
+ cmark
clang
devhelp-with-libsoup2
+ d-spy
+ ;; Cyclic modular dependency
+ (module-ref
+ (resolve-interface
+ '(gnu packages text-editors))
+ 'editorconfig-core-c)
flatpak
- glade3
gspell
- gtk+
+ gtk
json-glib
jsonrpc-glib
+ libadwaita
libdazzle
+ libdex
libgit2-glib
- libhandy
+ libpanel
libpeas
libportal
- libsoup-minimal-2
+ libsoup
llvm
libostree
python
python-pygobject
- sysprof-3.44
+ sysprof
template-glib
- vte
- webkitgtk-with-libsoup2))
+ vte-with-gtk-4
+ webkitgtk))
(propagated-inputs
- (list gtksourceview-4)) ;needed for settings
+ (list gtksourceview)) ;needed for settings
(native-inputs
(list desktop-file-utils ;for desktop-file-validate
`(,glib "bin")
gettext-minimal
+ gi-docgen
pkg-config
python ;for meson scripts
vala