summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-17 12:16:09 +0000
committerEric Bavier <bavier@posteo.net>2023-11-18 19:56:32 -0600
commit7a4c272619e1c0de9ab7aa76ddd59829087c391a (patch)
treeea145737a9a86abdc71c6477cfa8a3ce3db68aad
parent178871ff67a2eec93fe04b58b9d6bc8bf7ca71d0 (diff)
downloadguix-patches-7a4c272619e1c0de9ab7aa76ddd59829087c391a.tar
guix-patches-7a4c272619e1c0de9ab7aa76ddd59829087c391a.tar.gz
gnu: python-astroquery: Improve package style.
* gnu/packages/astronomy.scm (python-astroquery): Improve package style. [build-system]: Swap to pyproject-build-system. [arguments]{phases}: Rename 'writable-home phase to 'prepare-test-environment to reflect the purpose, Add extra step configuring Pytest. [native-inputs]: Remove python-flask, python-jinja2. Add python-astropy-healpix, python-regions. Change-Id: Id3909a13e451a2f9d5f4f28511e9f04c6bceb738 Signed-off-by: Eric Bavier <bavier@posteo.net>
-rw-r--r--gnu/packages/astronomy.scm41
1 files changed, 25 insertions, 16 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index e9caced125..d12dccc208 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1614,19 +1614,27 @@ astronomy and astrophysics.")
(uri (pypi-uri "astroquery" version))
(sha256
(base32 "1vhkzsqlgn3ji5by2rdf2gwklhbyzvpzb1iglalhqjkkrdaaaz1h"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (add-before 'check 'writable-home
- (lambda _ ; some tests need a writable home
- (setenv "HOME" (getcwd))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "--pyargs" "astroquery"
- ;; Skip tests that require online data.
- "-m" "not remote_data")))))))
+ (list
+ #:test-flags
+ #~(list "--pyargs" "astroquery"
+ "-m" "not remote_data")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'prepare-test-environment
+ (lambda _
+ (setenv "HOME" (getcwd)) ; some tests need a writable home
+ ;; To solve pytest/conftest issue. Pytest tries to load all
+ ;; files with word 'test' in them.
+ ;;
+ ;; ImportError while loading conftest ...
+ ;; _pytest.pathlib.ImportPathMismatchError: ...
+ ;;
+ (call-with-output-file "pytest.ini"
+ (lambda (port)
+ (format port "[pytest]
+python_files = test_*.py"))))))))
(propagated-inputs
(list python-astropy
python-beautifulsoup4
@@ -1636,12 +1644,13 @@ astronomy and astrophysics.")
python-pyvo
python-requests))
(native-inputs
- (list python-flask
- python-jinja2
+ (list python-astropy-healpix
python-matplotlib
+ ;; python-mocpy : Not packed yet, optional
python-pytest-astropy
- python-pytest-dependency))
- (home-page "https://www.astropy.org/astroquery/")
+ python-pytest-dependency
+ python-regions))
+ (home-page "https://astroquery.readthedocs.io/en/latest/index.html")
(synopsis "Access online astronomical data resources")
(description "Astroquery is a package that contains a collection of tools
to access online Astronomical data. Each web service has its own sub-package.")