summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-19 23:58:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-20 08:38:19 -0400
commit10d5535c784fc1c78c574268011eb616837d4315 (patch)
treedcec3814335cbf311bbce682d84aaa0b957b2ef2
parentc3b110b27ab6b111a279b6c033543ced1614d1be (diff)
downloadguix-patches-10d5535c784fc1c78c574268011eb616837d4315.tar
guix-patches-10d5535c784fc1c78c574268011eb616837d4315.tar.gz
gnu: python-aioredis: Deprecate by python-redis.
* gnu/packages/databases.scm (python-aioredis): Mark as deprecated by python-redis.
-rw-r--r--gnu/packages/databases.scm38
1 files changed, 3 insertions, 35 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 080645708d..e51ddd5bf2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3933,41 +3933,6 @@ for Python. The design goals are:
parsing code in hiredis. It primarily speeds up parsing of multi bulk replies.")
(license license:bsd-3)))
-(define-public python-aioredis
- (package
- (name "python-aioredis")
- (version "2.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "aioredis" version))
- (sha256
- (base32 "13nrkk45az6qdiwfpbw80ls6bfip0i27qlkh9gsp2b9zk6pim9ga"))))
- (build-system python-build-system)
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-before 'check 'start-redis
- (lambda _
- (invoke "redis-server" "--daemonize" "yes")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
- (native-inputs
- (list python-pytest
- python-pytest-asyncio
- python-uvloop
- redis))
- (propagated-inputs
- (list python-async-timeout
- python-hiredis
- python-typing-extensions))
- (home-page "https://github.com/aio-libs/aioredis-py")
- (synopsis "Redis support for Python's @code{asyncio} module")
- (description "This package provides Redis support for the Python
-@code{asyncio} (PEP 3156) module.")
- (license license:expat)))
-
(define-public python-fakeredis
(package
(name "python-fakeredis")
@@ -4061,6 +4026,9 @@ reasonable substitute.")
"This package provides a Python interface to the Redis key-value store.")
(license license:expat)))
+(define-public python-aioredis
+ (deprecated-package "python-aioredis" python-redis))
+
(define-public python-rq
(package
(name "python-rq")