summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-21 11:33:27 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-21 11:33:27 +0200
commit682cb004613859fa90f27a26fae621b7d98d8a3c (patch)
tree6d4bfee2174094725808e970d538f329740d6d01
parentdb90b40dfd9eeff10d4ba88c28d8eef85d72dd04 (diff)
downloadguix-patches-682cb004613859fa90f27a26fae621b7d98d8a3c.tar
guix-patches-682cb004613859fa90f27a26fae621b7d98d8a3c.tar.gz
gnu: guile-static: Add missing hunk in guile-default-utf8.patch.
Before that, the ‘guile’ binary from ‘guile-static-stripped’ would abort as it tries and fails to open an iconv descriptor for ISO-8859-1. * gnu/packages/patches/guile-default-utf8.patch: Add missing hunk for Guile 2.0.9.
-rw-r--r--gnu/packages/patches/guile-default-utf8.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/guile-default-utf8.patch b/gnu/packages/patches/guile-default-utf8.patch
index 409f435161..22771324f4 100644
--- a/gnu/packages/patches/guile-default-utf8.patch
+++ b/gnu/packages/patches/guile-default-utf8.patch
@@ -109,3 +109,14 @@ index 5d0db23..8266247 100644
(enum iconv_ilseq_handler) handler, NULL,
&buf, &len);
+--- guile-2.0.9/libguile/ports.c 2013-08-21 11:08:50.000000000 +0200
++++ guile-2.0.9/libguile/ports.c 2013-08-21 11:09:47.000000000 +0200
+@@ -2512,7 +2512,7 @@ scm_i_port_iconv_descriptors (SCM port,
+ const char *precise_encoding;
+
+ if (!pt->encoding)
+- pt->encoding = "ISO-8859-1";
++ pt->encoding = "UTF-8";
+
+ /* If the specified encoding is UTF-16 or UTF-32, then make
+ that more precise by deciding what byte order to use. */