summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-02-25 20:55:02 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-16 23:03:18 +0100
commitc27da3241ced3ec69586813dae18a123f9634f54 (patch)
tree4727f25f981cce86e0d31b04c3d17228d7484bbf
parent83128f00e9149f3c1bcd4450eb0ed3620a37149c (diff)
downloadguix-patches-c27da3241ced3ec69586813dae18a123f9634f54.tar
guix-patches-c27da3241ced3ec69586813dae18a123f9634f54.tar.gz
gnu: Add dropwatch.
* gnu/packages/networking.scm (dropwatch): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/networking.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index bf5f7ad2e7..3fac05c411 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4618,3 +4619,31 @@ interface statistics provided by the kernel as information source. This means
that vnStat won't actually be sniffing any traffic and also ensures light use
of system resources regardless of network traffic rate.")
(license license:gpl2+)))
+
+(define-public dropwatch
+ (package
+ (name "dropwatch")
+ (version "1.5.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nhorman/dropwatch.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r653y7bx763fpxl1vrflx8bzcrbds98zk4z7yhfikjngrqn1f2d"))))
+ (build-system gnu-build-system)
+ ;; XXX: bfd support isn't finished.
+ ;; https://github.com/nhorman/dropwatch/issues/76#issuecomment-1328345444
+ (arguments
+ (list #:configure-flags #~(list "--without-bfd")))
+ (native-inputs (list autoconf automake pkg-config))
+ (inputs (list libnl libpcap readline))
+ (home-page "https://github.com/nhorman/dropwatch")
+ (synopsis "Monitor for network packets dropped by the kernel")
+ (description
+ "Dropwatch is an interactive utility for monitoring and
+recording packets that are dropped by the kernel. It provides the commands
+@command{dropwatch} and @command{dwdump}.")
+ (license license:gpl2+)))