summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-06-27 16:11:15 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-06-28 10:51:40 +0300
commit4cd2dfd9f4d06c5f21cd40ac2e6b2896fe3cf78c (patch)
tree0ac1c6f61aa76b0e455171f3e265a35ab6aacf35
parent5e5bcba29576698fe50bcf9cc8e4de2576583d2d (diff)
downloadguix-patches-4cd2dfd9f4d06c5f21cd40ac2e6b2896fe3cf78c.tar
guix-patches-4cd2dfd9f4d06c5f21cd40ac2e6b2896fe3cf78c.tar.gz
gnu: emacs-nov-el: Use version tag instead of commit.
* gnu/packages/emacs-xyz.scm (emacs-nov-el): Remove let binding and associated comment; correct indentation. [source]: Use version tag as commit identifier now that upstream has restored this information. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/emacs-xyz.scm65
1 files changed, 31 insertions, 34 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d62f120e84..ea94120a0a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12550,39 +12550,36 @@ the format.")
(license license:gpl3+)))
(define-public emacs-nov-el
- ;; Upstream does not tag releases. Specify raw commit hash matching the
- ;; release.
- (let ((commit "ea0c835c1b5e6e70293f4bd64e9c89bdc42f8596"))
- (package
- (name "emacs-nov-el")
- (version "0.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://depp.brause.cc/nov.el.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "04phmm14ywgicjsl2bsg6w9rapd71vdkxdp5wp0brj6px27y85jz"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'embed-path-to-unzip
- (lambda _
- (substitute* "nov.el"
- (("\\(executable-find \"unzip\"\\)")
- (string-append "\"" (which "unzip") "\"")))
- #t)))))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-esxml" ,emacs-esxml)))
- (inputs
- `(("unzip" ,unzip)))
- (home-page "https://depp.brause.cc/nov.el/")
- (synopsis "Major mode for reading EPUBs in Emacs")
- (description "@code{nov.el} provides a major mode for reading EPUB
+ (package
+ (name "emacs-nov-el")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://depp.brause.cc/nov.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04phmm14ywgicjsl2bsg6w9rapd71vdkxdp5wp0brj6px27y85jz"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'embed-path-to-unzip
+ (lambda _
+ (substitute* "nov.el"
+ (("\\(executable-find \"unzip\"\\)")
+ (string-append "\"" (which "unzip") "\"")))
+ #t)))))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-esxml" ,emacs-esxml)))
+ (inputs
+ `(("unzip" ,unzip)))
+ (home-page "https://depp.brause.cc/nov.el/")
+ (synopsis "Major mode for reading EPUBs in Emacs")
+ (description "@code{nov.el} provides a major mode for reading EPUB
documents.
Features:
@@ -12599,7 +12596,7 @@ Features:
@item Image rescaling
@end itemize
")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public epipe
(package