summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWamm K. D <jaft.r@outlook.com>2022-10-24 11:46:42 -0500
committerChristopher Baines <mail@cbaines.net>2023-03-16 18:37:01 +0000
commite97ab7fff7f3c9c4833272602951883bfeddba62 (patch)
tree95a1aebe4400ccb234b9a8089068e8b03d1a305b
parentb59f89cf18fbad9ee95521c4cadc6642c580feb8 (diff)
downloadguix-patches-e97ab7fff7f3c9c4833272602951883bfeddba62.tar
guix-patches-e97ab7fff7f3c9c4833272602951883bfeddba62.tar.gz
gnu: Add python-rollbar.
* gnu/packages/python-xyz.scm (python-rollbar): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 81c9d93c9c..7c8b3b3378 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4054,6 +4054,35 @@ cutting and pasting that code over and over.")
to Roman Numerals.")
(license license:psfl)))
+(define-public python-rollbar
+ (package
+ (name "python-rollbar")
+ (version "0.16.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "rollbar" version))
+ (sha256
+ (base32
+ "1qpd0j50wqli3867xmhwk65pm1cxjs60yg83mcvcf3kic3y3sc82"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest-runner python-unittest2))
+ (inputs (list python-requests python-six python-httpx python-blinker
+ python-webob))
+ (home-page "https://github.com/rollbar/pyrollbar")
+ (synopsis "Notifier for exceptions, errors, and log messages to Rollbar")
+ (description
+ "Python SDK for reporting exceptions, errors, and log messages
+to @url{https://rollbar.com/, Rollbar}.
+
+Capabilities include:
+
+@itemize @bullet
+@item Sending messages and exceptions with arbitrary context
+@item Getting back aggregates
+@item Debugging production issues
+@end itemize")
+ (license license:expat)))
+
(define-public python-unidecode
(package
(name "python-unidecode")