summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorconses <contact@conses.eu>2023-03-17 09:14:46 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-17 09:22:49 +0100
commit156aac1b36c674ebcaf8876f40815ce56fa90662 (patch)
treeb677f80d3955d38f352395d8324d1ea5eec75f59
parent1b646419552c703f6a13b8f4d1b37ca3c77d7c4f (diff)
downloadguix-patches-156aac1b36c674ebcaf8876f40815ce56fa90662.tar
guix-patches-156aac1b36c674ebcaf8876f40815ce56fa90662.tar.gz
gnu: emacs-helpful: Update to 0.19-1.1c98f6f.
* gnu/packages/emacs-xyz.scm (emacs-helpful): Update to 0.19-1.1c98f6f. [source]: Remove fix-docstring-test.patch. [propagated-inputs]: Remove EMACS-SHUT-UP. * gnu/packages/patches/emacs-helpful-fix-docstring-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Apply removal. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emacs-xyz.scm52
-rw-r--r--gnu/packages/patches/emacs-helpful-fix-docstring-test.patch18
3 files changed, 26 insertions, 45 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f8061e4a34..4a662efc3c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1068,7 +1068,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-git-email-missing-parens.patch \
%D%/packages/patches/emacs-fix-scheme-indent-function.patch \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
- %D%/packages/patches/emacs-helpful-fix-docstring-test.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
%D%/packages/patches/emacs-native-comp-driver-options.patch \
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e0c7e97f68..68bac3121b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23374,31 +23374,31 @@ downloading manager for Emacs.")
(license license:gpl3+))))
(define-public emacs-helpful
- (package
- (name "emacs-helpful")
- (version "0.19")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Wilfred/helpful")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0qwsifzsjw95l83m7z07fr9h1sqbhggwmcps1qgbddpan2a8ab8a"))
- ;; Cherry-picked from upstream, remove when bumping to 0.20.
- (patches (search-patches "emacs-helpful-fix-docstring-test.patch"))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-elisp-refs emacs-dash emacs-s emacs-f emacs-shut-up))
- (native-inputs
- (list emacs-ert-runner emacs-undercover))
- (arguments
- `(#:tests? #t
- #:test-command '("ert-runner")))
- (home-page "https://github.com/Wilfred/helpful")
- (synopsis "More contextual information in Emacs help")
- (description "@code{helpful} is an alternative to the built-in Emacs help
+ (let ((commit "1c98f6f06a85def5d34c735f8cd407f20cebddf9")
+ (revision "1"))
+ (package
+ (name "emacs-helpful")
+ (version (git-version "0.19" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Wilfred/helpful")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18b5hjfji51zxjrxhkklxx3j9svk295awmxv8n95mp8ilas2kd3l"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash emacs-elisp-refs emacs-f emacs-s))
+ (native-inputs
+ (list emacs-ert-runner emacs-undercover))
+ (arguments
+ `(#:tests? #t
+ #:test-command '("ert-runner")))
+ (home-page "https://github.com/Wilfred/helpful")
+ (synopsis "More contextual information in Emacs help")
+ (description "@code{helpful} is an alternative to the built-in Emacs help
that provides much more contextual information.
@itemize
@@ -23417,7 +23417,7 @@ functions.
@item Trace, disassemble functions from inside Helpful. This is discoverable
and doesn't require memorisation of commands.
@end itemize\n")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-logview
(package
diff --git a/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch b/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch
deleted file mode 100644
index de40010fa2..0000000000
--- a/gnu/packages/patches/emacs-helpful-fix-docstring-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-This patch fixing a build failure has been cherry-picked from upstream.
-Originally submitted as pull request by Erik Šabič.
-See also <https://github.com/Wilfred/helpful/pull/296>.
-diff --git a/test/helpful-unit-test.el b/test/helpful-unit-test.el
-index a07aa8e..8a95129 100644
---- a/test/helpful-unit-test.el
-+++ b/test/helpful-unit-test.el
-@@ -119,7 +119,9 @@ bar")))
- (should
- (equal
- (helpful--docstring #'test-foo-advised t)
-- "Docstring here too.")))
-+ (if (version< emacs-version "28")
-+ "Docstring here too."
-+ "Docstring here too.\n\nThis function has :around advice: `ad-Advice-test-foo-advised'."))))
-
- (defun test-foo-no-docstring ()
- nil)