summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRostislav Svoboda <rostislav.svoboda@gmail.com>2023-03-11 14:08:45 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-16 00:10:50 +0100
commit28bf6720e7d2becd25371e6d069365e583e5988f (patch)
treeda0607d4ede0175601bc7ef7620e71337006e3d9
parent4496ff34a31cad104cf43e4860b9df7014a9d98e (diff)
downloadguix-patches-28bf6720e7d2becd25371e6d069365e583e5988f.tar
guix-patches-28bf6720e7d2becd25371e6d069365e583e5988f.tar.gz
gnu: Add emacs-xcscope.
* gnu/packages/emacs-xyz.scm (emacs-xcscope): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8974794221..dba52d4918 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4176,6 +4176,39 @@ lines spanning the entire window. The minor mode is suitable for inclusion
into mode hooks and is intended to be used that way.")
(license license:gpl3+)))
+(define-public emacs-xcscope
+ (let ((commit "d228d7593d762e457340f678d14b663ef66d7cee")
+ (revision "0"))
+ (package
+ (name "emacs-xcscope")
+ (version (git-version "1.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dkogan/xcscope.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pr85ywp585imjzswm04647nb4iqqvg8jgmbcs5210qmr9kh0z8d"))))
+ (build-system emacs-build-system)
+ (inputs (list cscope))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'substitute-cscope-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "xcscope.el"
+ ("cscope-program"
+ (search-input-file inputs "/bin/cscope"))))))))
+ (home-page "https://github.com/dkogan/xcscope.el")
+ (synopsis "Interface to the source cross-referencing tool Cscope")
+ (description
+ "Xcscope is an Emacs interface to Cscope, the source cross-referencing
+tool.")
+ (license license:gpl2+))))
+
(define-public emacs-ggtags
(package
(name "emacs-ggtags")