summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-03-08 23:26:35 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-16 00:10:58 +0100
commit0689a842710e5831d9de12964ec1fd38b360e022 (patch)
tree8a069f254f2cde933afb6da3f0cc3ad21b308393
parent021bc8567de64172fad68573ba1f73740fd2bdde (diff)
downloadguix-patches-0689a842710e5831d9de12964ec1fd38b360e022.tar
guix-patches-0689a842710e5831d9de12964ec1fd38b360e022.tar.gz
gnu: Add python-czml3.
* gnu/packages/astronomy.scm (python-czml3): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/astronomy.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1c39c2a181..88628fc122 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1281,6 +1281,37 @@ attempting to maintain ISTP compliance
@end itemize")
(license license:expat)))
+(define-public python-czml3
+ (package
+ (name "python-czml3")
+ (version "0.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/poliastro/czml3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pbwcsmc9nw591rck586ca9hwwhmm54rjjmp8gflhzq8b7f48lkc"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-attrs
+ python-dateutil
+ python-w3lib))
+ (native-inputs
+ (list python-astropy
+ python-pytest
+ python-pytest-cov
+ python-pytest-mypy))
+ (home-page "https://github.com/poliastro/czml3")
+ (synopsis "Python library to write CZML")
+ (description
+ "CZML3 is a Python library to write CZML, a JSON format for describing
+a time-dynamic graphical scene, primarily for display in a web browser running
+Cesium.")
+ (license license:expat)))
+
(define-public python-drms
(package
(name "python-drms")