summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-12 18:43:34 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-16 00:10:58 +0100
commit021bc8567de64172fad68573ba1f73740fd2bdde (patch)
treee8b0b54e3cd096ef3e83313798d790f50da3bfa3
parenta148da0125ac74d842c17d9743412e4fe926c308 (diff)
downloadguix-patches-021bc8567de64172fad68573ba1f73740fd2bdde.tar
guix-patches-021bc8567de64172fad68573ba1f73740fd2bdde.tar.gz
gnu: xmoto: Update to 0.6.2.
* gnu/packages/games.scm (xmoto): Update to 0.6.2. [arguments]<#:phases>: Follow SDL2 switch. [inputs]: Delete LUA-5.1, SDL, SDL-MIXER, SDL-NET and SDL-TTF. Add LUA, SDL2, SDL2-mixer, SDL2-NET and SDL2-TTF.
-rw-r--r--gnu/packages/games.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a0d7d68c2f..31523777bd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10147,16 +10147,16 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
(define-public xmoto
(package
(name "xmoto")
- (version "0.6.1")
+ (version "0.6.2")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/xmoto/xmoto")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "00f5ha79lfa2iiaz66wl0hl5dapa1l15qdr7m7knzi0ll7j6z66n"))
+ (base32 "14z3yqpiyv4y5l37b12kf8ipgsmb9krb4b5d9adlrry0j43hd7wz"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -10190,7 +10190,7 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
(string-append
- (assoc-ref inputs "sdl") "/include/SDL:"
+ (assoc-ref inputs "sdl") "/include/SDL2:"
(or (getenv "CPATH") "")))
#t))
(add-after 'install 'unbundle-fonts
@@ -10219,9 +10219,9 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
("libpng" ,libpng)
("libxdg-basedir" ,libxdg-basedir)
("libxml2" ,libxml2)
- ("lua" ,lua-5.1)
+ ("lua" ,lua)
("ode" ,ode)
- ("sdl" ,(sdl-union (list sdl sdl-mixer sdl-net sdl-ttf)))
+ ("sdl" ,(sdl-union (list sdl2 sdl2-mixer sdl2-net sdl2-ttf)))
("sqlite" ,sqlite)
("zlib" ,zlib)))
(home-page "https://xmoto.tuxfamily.org/")