summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2023-01-09 16:06:20 +0100
committerAndreas Enge <andreas@enge.fr>2023-03-11 23:18:28 +0100
commit7ace062f3eabf1c50f169cac6d5692fdbeb9aec7 (patch)
tree29ceb55c76bddf9251eda4ea6e5b5a5d9355b909
parent962277fd4313f20c0e0333effbd88352c0a7d461 (diff)
downloadguix-patches-7ace062f3eabf1c50f169cac6d5692fdbeb9aec7.tar
guix-patches-7ace062f3eabf1c50f169cac6d5692fdbeb9aec7.tar.gz
gnu: Add python-scapy.
* gnu/packages/python-xyz.scm (python-scapy): New variable. Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83f3ec02ea..a6b9b5cdba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -132,6 +132,7 @@
;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1453,6 +1454,35 @@ top, lsof, netstat, ifconfig, who, df, kill, free, nice, ionice, iostat,
iotop, uptime, pidof, tty, taskset, pmap.")
(license license:bsd-3)))
+(define-public python-scapy
+ (package
+ (name "python-scapy")
+ (version "2.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "scapy" version))
+ (sha256
+ (base32
+ "1hpbbmpcn4dwj3z7i7sz4cnbpkaf57p7mvl3p84x9n2gflmhq9jv"))))
+ (arguments
+ '(#:tests? #f)) ; There is a test directory, but apparently no
+ ; automatic testing framework.
+ ;; The package has more optional dependencies such as ipython and
+ ;; matplotlib. If functionality is missing, these should be added.
+ ;; See
+ ;; https://scapy.readthedocs.io/en/latest/installation.html#optional-dependencies
+ (build-system python-build-system)
+ (home-page "https://scapy.net")
+ (synopsis "Python network packet crafting library")
+ (description
+ "Scapy is a Python library and executable for interactively
+manipulating network packets. It can forge or decode packets of a number
+of protocols, send them on the wire, capture them, store or read them
+using pcap files, match requests and replies, and so on.
+It can handle tasks such as scanning, tracerouting, probing, unit tests,
+attacks or network discovery.")
+ (license license:gpl2)))
+
(define-public python-shapely
(package
(name "python-shapely")