summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-03-11 13:39:31 +0000
committerLars-Dominik Braun <lars@6xq.net>2023-03-12 11:04:05 +0100
commit64d69c3f797bcf8911ce3d95c4adf288c4ef0e26 (patch)
tree861b670c4efce8097365b4bfc82175d5a5e9952e
parent94c898cd9bd229894dbf70a55e803c95b82af784 (diff)
downloadguix-patches-64d69c3f797bcf8911ce3d95c4adf288c4ef0e26.tar
guix-patches-64d69c3f797bcf8911ce3d95c4adf288c4ef0e26.tar.gz
gnu: python-jupytext: Replace python-pre-commit with pre-commit.
* gnu/packages/python-xyz.scm (python-jupytext)[native-inputs]: Remove python-pre-commit. [native-inputs]: Add pre-commit. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6b9b5cdba..7ab6c38c80 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -352,6 +352,7 @@ design}.")
" and not "))))))))))
(native-inputs
(list git-minimal
+ pre-commit
python-autopep8
python-black
python-flake8
@@ -359,7 +360,6 @@ design}.")
python-isort
python-ipython-genutils
python-jupyter-server
- python-pre-commit
python-pytest
python-pyaml))
(propagated-inputs