summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-11-20 15:11:51 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-11-21 10:18:48 +0100
commit3612bd925f0256a9896d88114683c571c7f5c03d (patch)
treecdb8d46a876fb6bd76b73217b585192c098e1140
parentc0037bd5080460c88aa80000e8fa5d8f3493c335 (diff)
downloadguix-patches-3612bd925f0256a9896d88114683c571c7f5c03d.tar
guix-patches-3612bd925f0256a9896d88114683c571c7f5c03d.tar.gz
gnu: Add cl-the-cost-of-nothing.
* gnu/packages/lisp-xyz.scm (sbcl-the-cost-of-nothing, cl-the-cost-of-nothing, ecl-the-cost-of-nothing): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d9c8768308..94975dcea6 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15097,6 +15097,46 @@ even by adding additional statistical @code{compute}ations.")
(define-public ecl-trivial-benchmark
(sbcl-package->ecl-package sbcl-trivial-benchmark))
+(define-public sbcl-the-cost-of-nothing
+ (let ((commit "f364029fbbf37ae5786f2f9ddf6185dd204a7185")
+ (revision "0"))
+ (package
+ (name "sbcl-the-cost-of-nothing")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marcoheisig/the-cost-of-nothing")
+ (commit commit)))
+ (file-name (git-file-name "cl-the-cost-of-nothing" version))
+ (sha256
+ (base32 "1ccrglyr1wnnfp218w1qj7yfl4yzlxkki3hqaifi5axgbi5dmmh8"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ ;; The test operation benchmarks the Common Lisp implementation; it
+ ;; doesn't test the package.
+ (list #:tests? #f))
+ (inputs
+ (list sbcl-alexandria
+ sbcl-closer-mop
+ sbcl-local-time
+ sbcl-trivial-garbage))
+ (home-page "https://github.com/marcoheisig/the-cost-of-nothing")
+ (synopsis "Measure the run time of Common Lisp code")
+ (description
+ "THE-COST-OF-NOTHING is a library for measuring the run time of Common
+Lisp code. It provides macros and functions for accurate benchmarking and
+lightweight monitoring. Furthermore, it provides predefined benchmarks to
+determine the cost of certain actions on a given platform and implementation.")
+ (license license:expat))))
+
+(define-public cl-the-cost-of-nothing
+ (sbcl-package->cl-source-package sbcl-the-cost-of-nothing))
+
+(define-public ecl-the-cost-of-nothing
+ (sbcl-package->ecl-package sbcl-the-cost-of-nothing))
+
(define-public sbcl-glyphs
(let ((commit "1ff5714e8c1dca327bc604dfe3e3d1f4b7755373"))
(package