summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-03-11 13:39:44 +0000
committerLars-Dominik Braun <lars@6xq.net>2023-03-12 11:04:07 +0100
commit831baaf81e57ce9d9053ba6f9e0653a2d27298c4 (patch)
tree49663ef2ece947c2aff94575db8a83d0b1300a15
parent5c976c6b45a85efcb82c341f0f3f961cd72deb80 (diff)
downloadguix-patches-831baaf81e57ce9d9053ba6f9e0653a2d27298c4.tar
guix-patches-831baaf81e57ce9d9053ba6f9e0653a2d27298c4.tar.gz
gnu: python-pre-commit: Replace with pre-commit.
* gnu/packages/python-xyz.scm (python-pre-commit): Deprecate in favor of pre-commit. Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 20de20a229..9daacb9777 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24317,34 +24317,7 @@ Features:
(license license:asl2.0)))
(define-public python-pre-commit
- (package
- (name "python-pre-commit")
- (version "2.10.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pre_commit" version))
- (sha256
- (base32 "1ycf6wpxrhxhdzz0vpryhbdxlwik5khgcvp3hxwvfr447a6k84zl"))))
- (build-system python-build-system)
- (arguments
- ;; Tests fail with "AttributeError: module 'pre_commit.resources' has no
- ;; attribute 'empty_template_setup'".
- `(#:tests? #false))
- (propagated-inputs
- (list python-cfgv
- python-identify
- python-importlib-metadata
- python-nodeenv
- python-pyyaml
- python-toml
- python-virtualenv))
- (home-page "https://github.com/pre-commit/pre-commit")
- (synopsis "Framework for managing multi-language pre-commit hooks")
- (description
- "This package provides a framework for managing and maintaining
-multi-language pre-commit hooks.")
- (license license:expat)))
+ (deprecated-package "python-pre-commit" pre-commit))
(define-public python-precis-i18n
(package