summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2023-03-06 15:47:25 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-03-07 09:07:17 +0800
commit764ab3786e50d456ad2e624452d3cacc187ae63b (patch)
tree2070618feb76656add0b6e34316a838ad9992b5c
parente6ed6ab7f3111addda6cda886320ab35e7577e40 (diff)
downloadguix-patches-764ab3786e50d456ad2e624452d3cacc187ae63b.tar
guix-patches-764ab3786e50d456ad2e624452d3cacc187ae63b.tar.gz
gnu: Add jwm.
* gnu/packages/wm.scm (jwm): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/wm.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 5b8dbd5c70..c1cbd00cf5 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2777,6 +2777,61 @@ read and write, and compatible with JSON.")
capabilities. It is heavily inspired by the Calm Window manager(cwm).")
(license license:bsd-2)))
+(define-public jwm
+ (package
+ (name "jwm")
+ (version "2.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/joewing/jwm/releases/download/"
+ "v" version "/jwm-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1av7r9sp26r5l74zvwdmyyyzav29mw5bafihp7y33vsjqkh4wfzf"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no check target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-xsession
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (xsessions (string-append out "/share/xsessions")))
+ (mkdir-p xsessions)
+ (call-with-output-file
+ (string-append xsessions "/jwm.desktop")
+ (lambda (port)
+ (format port "~
+ [Desktop Entry]~@
+ Name=jwm~@
+ Comment=Joe's Window Manager~@
+ Exec=~a/bin/jwm~@
+ Type=XSession~%" out)))))))))
+ (native-inputs (list pkg-config))
+ (inputs
+ (list cairo
+ libjpeg-turbo
+ libpng
+ librsvg
+ libxext
+ libxinerama
+ libxmu
+ libxpm
+ libxrender
+ libxt
+ pango))
+ (home-page "http://joewing.net/projects/jwm")
+ (synopsis "Joe's Window Manager")
+ (description
+ "JWM is a light-weight window manager for the X11 Window System. it is
+written in C and uses only Xlib at a minimum. Because of its small footprint,
+it makes a good window manager for older computers and less powerful systems,
+such as the Raspberry Pi, though it is perfectly capable of running on modern
+systems.")
+ (license license:expat)))
+
(define-public devour
(package
(name "devour")