summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2023-03-06 15:47:26 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-03-07 09:07:35 +0800
commit61a0b03c65bd9b1056075d1f78487d2259526a07 (patch)
treedb255df789172baa7908979d2fa505f9ff4c5f14
parent764ab3786e50d456ad2e624452d3cacc187ae63b (diff)
downloadguix-patches-61a0b03c65bd9b1056075d1f78487d2259526a07.tar
guix-patches-61a0b03c65bd9b1056075d1f78487d2259526a07.tar.gz
gnu: Add mjwm.
* gnu/packages/wm.scm (mjwm): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/wm.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c1cbd00cf5..3f4c648901 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2832,6 +2832,39 @@ such as the Raspberry Pi, though it is perfectly capable of running on modern
systems.")
(license license:expat)))
+(define-public mjwm
+ (package
+ (name "mjwm")
+ (version "4.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chiku/mjwm")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lgfp2xidhvmbj4zqvzz9g8zwbn6mz0pgacc57b43ha523vamsjq"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no check target
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-subcategory.h
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "include/subcategory.h"
+ ;; icon name should be application-other instead of
+ ;; application-others.
+ (("applications-others") "applications-other")))))))
+ (home-page "https://github.com/chiku/mjwm")
+ (synopsis "Create menu for JWM")
+ (description
+ "MJWM can create JWM's menu from (freedesktop) desktop files and the
+generated file can be include in the rootmenu section of your jwm config
+file.")
+ (license license:gpl2+)))
+
(define-public devour
(package
(name "devour")