summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-03-06 23:42:23 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-07 10:55:51 +0100
commite08ae5900a16ac29e6adc369f513f574137eb86e (patch)
tree30273746f1f3ec310e8dc4ee36e93a80818cf687
parent66f7d95d027d74ae6e9c9d37c80ed65b5c96dc40 (diff)
downloadguix-patches-e08ae5900a16ac29e6adc369f513f574137eb86e.tar
guix-patches-e08ae5900a16ac29e6adc369f513f574137eb86e.tar.gz
gnu: raylib: Build shared libraries.
* gnu/packages/game-development.scm (raylib): [arguments]{#:configure-flags}: Enable building shared libraries. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/game-development.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a0de1b339e..a384572a9d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2847,12 +2847,15 @@ progresses the level, or you may regenerate tiles as the world changes.")
(url "https://github.com/raysan5/raylib/")
(commit version)))
(file-name (git-file-name name version))
+ ;; TODO: Unbundle src/external
(sha256
(base32
"14v5iwxh8grywiyw9agpd2sfpyriq1rwwkd9f2s4iihh0z5j7hk8"))))
(build-system cmake-build-system)
(arguments
- (list #:tests? #f)) ;no test
+ (list #:tests? #f ;no test
+ #:configure-flags
+ #~(list "-DBUILD_SHARED_LIBS=ON" )))
(inputs (list alsa-lib
libx11
libxrandr