summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-28 00:12:27 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-07 11:39:50 +0100
commitaaf7e31d1912cc05c9bf3163a951bfa91bc129db (patch)
tree395a0708004aa34f3378b465812b4615bca1ea6b
parent8390b47c045efca88785b5ed9210cb7aa13cb63a (diff)
downloadguix-patches-aaf7e31d1912cc05c9bf3163a951bfa91bc129db.tar
guix-patches-aaf7e31d1912cc05c9bf3163a951bfa91bc129db.tar.gz
gnu: Add calcmysky.
* gnu/packages/astronomy.scm (calcmysky, calcmysky-qt5): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/astronomy.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index b6ed1e2f49..0b9be40d97 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -210,6 +210,63 @@ moment, supported SPICE files are:
@end itemize\n")
(license license:cecill)))
+(define-public calcmysky
+ (package
+ (name "calcmysky")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/10110111/CalcMySky")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0bib5shy8wzc7j5ph218dl9hqrqip491mn25gakyghbvaqxgm27d"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=6"
+ "-DCMAKE_CXX_FLAGS=-fPIC")))
+ (inputs
+ (list eigen glm qtbase))
+ (home-page "https://10110111.github.io/CalcMySky/")
+ (synopsis "Simulator of light scattering by planetary atmospheres")
+ (description
+ "CalcMySky is a software package that simulates scattering of light by the
+atmosphere to render daytime and twilight skies (without stars). Its primary
+purpose is to enable realistic view of the sky in applications such as
+planetaria. Secondary objective is to make it possible to explore atmospheric
+effects such as glories, fogbows etc., as well as simulate unusual environments
+such as on Mars or an exoplanet orbiting a star with a non-solar spectrum of
+radiation.
+
+This package consists of three parts:
+
+@itemize
+@item @code{calcmysky} utility that does the precomputation of the atmosphere
+model to enable rendering.
+
+@item @code{libShowMySky} library that lets the applications render the
+atmosphere model.
+
+@item @code{ShowMySky} preview GUI that makes it possible to preview the
+rendering of the atmosphere model and examine its properties.
+@end itemize")
+ (license license:gpl3+)))
+
+(define-public calcmysky-qt5
+ (package/inherit calcmysky
+ (name "calcmysky-qt5")
+ (arguments
+ (list #:configure-flags
+ #~(list "-DQT_VERSION=5"
+ "-DCMAKE_CXX_FLAGS=-fPIC")))
+ (inputs
+ (modify-inputs (package-inputs calcmysky)
+ (replace "qtbase" qtbase-5)))
+ (synopsis "Qt5 build for the CalcMySky library.")))
+
(define-public aoflagger
(package
(name "aoflagger")