summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-03-02 00:09:55 -0800
committerLudovic Courtès <ludo@gnu.org>2023-03-05 23:06:55 +0100
commitfa059cb0019ded81dbe47d517ab1728e3954bf9c (patch)
tree5fdeb720b5033278b178b6f9c17f167d9c75234e
parent674d8933169e018efa3471e4eac52e5ea1e6afee (diff)
downloadguix-patches-fa059cb0019ded81dbe47d517ab1728e3954bf9c.tar
guix-patches-fa059cb0019ded81dbe47d517ab1728e3954bf9c.tar.gz
gnu: flatbuffers: Add version 23.1.21.
* gnu/packages/serialization.scm (flatbuffers-next): New variable as flatbuffers@2.0.0 is depended on by tensorflow-lite so we cannot just upgrade directly, so adding current release flatbuffers@23.1.21. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/serialization.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 8ab1efd311..3f0a550920 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -699,6 +699,20 @@ C#, C, Go, Java, JavaScript, PHP, and Python. It was originally created for
game development and other performance-critical applications.")
(license license:asl2.0)))
+(define-public flatbuffers-next
+ (package
+ (inherit flatbuffers)
+ (version "23.1.21")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/flatbuffers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "flatbuffers" version))
+ (sha256
+ (base32
+ "1z3a6l8g2y53i5xzraswfs2i0i3kk52zv7nzc2q3fgisbyiri3pz"))))))
+
(define-public python-feather-format
(package
(name "python-feather-format")