summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-02-11 22:44:27 -0500
committerLudovic Courtès <ludo@gnu.org>2023-03-04 18:46:37 +0100
commit0d6c5e0ba1bd6800712e79964f7b9f5c6043f249 (patch)
treec4e1c4f1369f7dc897b218ebb0a4e01052ba1d11
parenta6194d1f35ec8ac9b58f4d05affa5aabf1ca7014 (diff)
downloadguix-patches-0d6c5e0ba1bd6800712e79964f7b9f5c6043f249.tar
guix-patches-0d6c5e0ba1bd6800712e79964f7b9f5c6043f249.tar.gz
gnu: Remove and deprecate tidy for tidy-html
* gnu/packages/web.scm (tidy): Change to deprecated alias for tidy-html * gnu/packages/pumpio.scm (pumpa): Use tidy-html instead of tidy and correct header name. * gnu/packages/markup.scm (hoedown): * gnu/packages/photo.scm (enblend-enfuse): * gnu/packages/php.scm (php): * gnu/packages/python-xyz.scm (python-pytidylib): Use tidy-html instead of tidy. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/markup.scm2
-rw-r--r--gnu/packages/photo.scm2
-rw-r--r--gnu/packages/php.scm2
-rw-r--r--gnu/packages/pumpio.scm4
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/web.scm37
6 files changed, 10 insertions, 39 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 35dd6d257b..9162b008e0 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -73,7 +73,7 @@
#:test-target "test"))
(native-inputs
`(("python" ,python-2)
- ("tidy" ,tidy)))
+ ("tidy" ,tidy-html)))
(synopsis "Markdown processing library")
(description "Hoedown is a standards compliant, fast, secure markdown
processing library written in C.")
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 358247f32e..80fc963363 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -383,7 +383,7 @@ overlapping images, as well as some command line tools.")
imagemagick
libxml2
texlive-tiny
- tidy
+ tidy-html
transfig))
(inputs
(list boost
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index c2539ef7fc..c71d648cf4 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -416,7 +416,7 @@
("postgresql" ,postgresql)
("readline" ,readline)
("sqlite" ,sqlite)
- ("tidy" ,tidy)
+ ("tidy" ,tidy-html)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/pumpio.scm b/gnu/packages/pumpio.scm
index 2f4dd359d1..5fb6e338e8 100644
--- a/gnu/packages/pumpio.scm
+++ b/gnu/packages/pumpio.scm
@@ -47,6 +47,8 @@
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "src/util.cpp"
+ (("buffio\\.h") "tidybuffio.h"))
;; Fix dependency tests.
(substitute* "pumpa.pro"
(("/usr/include/tidy\\.h")
@@ -59,7 +61,7 @@
(invoke "qmake" prefix))
#t)))))
(inputs
- (list aspell qtbase-5 tidy))
+ (list aspell qtbase-5 tidy-html))
(synopsis "Qt-based pump.io client")
(description "Pumpa is a simple pump.io client written in C++ and Qt.")
(home-page "https://pumpa.branchable.com/")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f2e107fae2..db9067e699 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27219,7 +27219,7 @@ be necessary when using @code{cmd}.")
(("ctypes\\.util\\.find_library\\('tidy'\\)")
(format #f "'~a'" libtidy)))
#t))))))
- (inputs (list tidy))
+ (inputs (list tidy-html))
(home-page "https://github.com/countergram/pytidylib")
(synopsis "Python wrapper for HTML Tidy library")
(description
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 861f3e0419..cc206722a9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1718,40 +1718,6 @@ domains (UTF-8 and IDNA2008 Punycode), is thread-safe, and handles IDNA2008
UTS#46.")
(license license:x11)))
-(define-public tidy
- (package
- (name "tidy")
- (version "20091223")
- (source (origin
- (method cvs-fetch)
- (uri (cvs-reference
- (root-directory
- ":pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy")
- (module "tidy")
- (revision "2009-12-23")))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "14dsnmirjcrvwsffqp3as70qr6bbfaig2fv3zvs5g7005jrsbvpb"))
- (patches (search-patches "tidy-CVE-2015-5522+5523.patch"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'bootstrap
- (lambda* (#:key inputs #:allow-other-keys)
- ;; configure.in and Makefile.am aren't in the root of the
- ;; source tree.
- (copy-recursively "build/gnuauto" ".")
- (setenv "AUTOMAKE" "automake --foreign")
- (invoke "autoreconf" "-vfi"))))))
- (native-inputs
- (list automake autoconf libtool))
- (synopsis "HTML validator and tidier")
- (description "HTML Tidy is a command-line tool and C library that can be
-used to validate and fix HTML data.")
- (home-page "https://tidy.sourceforge.net/")
- (license (license:x11-style "file:///include/tidy.h"))))
-
(define-public esbuild
(package
(name "esbuild")
@@ -6204,6 +6170,9 @@ developers can integrate into their applications to make use of the
functions of Tidy.")
(license license:bsd-3)))
+(define-public tidy
+ (deprecated-package "tidy" tidy-html))
+
(define-public hiawatha
(package
(name "hiawatha")