summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-31 01:34:40 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-31 10:27:37 +0100
commitf8d8109369c6a70e69010a2522207302c73d2123 (patch)
treed365cb8429981dcf52fb1db9b93c9da22eb8e4f5
parentb41d8a702d1f0df22c04f58bd7174e4906c2857f (diff)
downloadguix-patches-f8d8109369c6a70e69010a2522207302c73d2123.tar
guix-patches-f8d8109369c6a70e69010a2522207302c73d2123.tar.gz
gnu: sbcl-deploy: Update to 1.0.0-2.9b20e64.
* gnu/packages/lisp-xyz.scm (sbcl-deploy): Update to 1.0.0-2.9b20e64. [arguments]: Add 'test-asd-file' and 'asd-files' parameters. [native-inputs]: Add cl-mpg123 and cl-out123. [inputs]: Add trivial-features. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3fa11ee7ba..7cfd4b2a6b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12390,9 +12390,8 @@ predictable cross-platform behavior and some utilities useful for versioning.")
(sbcl-package->ecl-package sbcl-defpackage-plus))
(define-public sbcl-deploy
- ;; tagged branch is outdated
- (let ((revision "1")
- (commit "59fd49719ef651a8fc11750bcfb337f132cff75f"))
+ (let ((commit "9b20e64fe924b9e31832304d87a3a72c383dc6d8")
+ (revision "2"))
(package
(name "sbcl-deploy")
(version (git-version "1.0.0" revision commit))
@@ -12402,15 +12401,21 @@ predictable cross-platform behavior and some utilities useful for versioning.")
(uri (git-reference
(url "https://github.com/Shinmera/deploy")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "deploy" version))
(sha256
- (base32 "1vl2116z4kw2pd3qd3n6mmg8g0mnwxr9dgddk86g7j1bis1z8k9a"))))
+ (base32 "07pfkibaridihg8lbq2czwa4iqifqk24n6rx7bfnv7i49p1ppja1"))))
(build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:test-asd-file "deploy-test.asd"
+ #:asd-files '("deploy.asd"
+ "deploy-test.asd")))
+ (native-inputs
+ `(("cl-mpg123" ,sbcl-cl-mpg123)
+ ("cl-out123" ,sbcl-cl-out123)))
(inputs
`(("cffi" ,sbcl-cffi)
- ("documentation-utils" ,sbcl-documentation-utils)))
- (arguments
- '(#:asd-files '("deploy.asd")))
+ ("documentation-utils" ,sbcl-documentation-utils)
+ ("trivial-features" ,sbcl-trivial-features)))
(home-page "https://shinmera.github.io/deploy/")
(synopsis "Deployment tools for standalone Common Lisp application")
(description