summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-03-03 11:56:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-03 12:04:24 +0100
commit4f681cdbc27e6a922f24d4297efe3c0b823195f0 (patch)
treee2451ec96a1aa258f282b94282bdda47dde03544
parent98cac9dcabbf15b156240876f5bd36707ea3f574 (diff)
downloadguix-patches-4f681cdbc27e6a922f24d4297efe3c0b823195f0.tar
guix-patches-4f681cdbc27e6a922f24d4297efe3c0b823195f0.tar.gz
gnu: Add r-oscope.
* gnu/packages/bioconductor.scm (r-oscope): New variable.
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 22be8d3772..d603bd42c1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7425,6 +7425,32 @@ annotation packages each of which has its own schema by taking advantage of
the fact that each of these packages implements a select methods.")
(license license:artistic2.0)))
+(define-public r-oscope
+ (package
+ (name "r-oscope")
+ (version "1.28.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Oscope" version))
+ (sha256
+ (base32
+ "0454f9yc0jmg3mcq9264wb5v2n8n0kaf801hlvsiy1xa3baj3h29"))))
+ (properties `((upstream-name . "Oscope")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocparallel r-cluster r-ebseq r-testthat))
+ (home-page "https://bioconductor.org/packages/Oscope")
+ (synopsis
+ "Oscillatory genes identifier in unsynchronized single cell RNA-seq")
+ (description
+ "Oscope is a oscillatory genes identifier in unsynchronized single cell
+RNA-seq. This statistical pipeline has been developed to identify and recover
+the base cycle profiles of oscillating genes in an unsynchronized single cell
+RNA-seq experiment. The Oscope pipeline includes three modules: a sine model
+module to search for candidate oscillator pairs; a K-medoids clustering module
+to cluster candidate oscillators into groups; and an extended nearest
+insertion module to recover the base cycle order for each oscillator group.")
+ (license license:asl2.0)))
+
(define-public r-pcaexplorer
(package
(name "r-pcaexplorer")