summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-01 22:14:30 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-01 22:16:50 +0100
commit43eed907d22b094c5a9b2931ca5e72caf2b95991 (patch)
treea39832495462f4e628195acc01f2d65bb0936f36
parent3046063645c9f564b1ce6c7f72b226ec4cd10407 (diff)
downloadguix-patches-43eed907d22b094c5a9b2931ca5e72caf2b95991.tar
guix-patches-43eed907d22b094c5a9b2931ca5e72caf2b95991.tar.gz
gnu: emacs-embark: Update to 0.21.1.
* gnu/packages/emacs-xyz.scm (emacs-embark): Update to 0.21.1.
-rw-r--r--gnu/packages/emacs-xyz.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 58a5035550..c2c0fb93ba 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10302,25 +10302,26 @@ them easier to distinguish from other, less important buffers.")
(license license:expat)))
(define-public emacs-embark
- (package
- (name "emacs-embark")
- (version "0.19")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oantolin/embark")
- (commit version)))
- (sha256
- (base32 "05c8p7rqv9p8p3nhgcjfr66hpsqazhnhwsnfdapxd9z7wrybqbg5"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-avy emacs-consult))
- (home-page "https://github.com/oantolin/embark")
- (synopsis "Emacs mini-buffer actions rooted in keymaps")
- (description
- "This package provides a sort of right-click contextual menu for Emacs
+ (let ((commit "63013c2d3ef4dccc95167218ccbf4f401e489c3e")) ;version bump
+ (package
+ (name "emacs-embark")
+ (version "0.21.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/embark")
+ (commit commit)))
+ (sha256
+ (base32 "14qp46wa1xgmb09jyk9cadj0b3m7bwspqnprk3zbfc6gw1r53235"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-avy emacs-consult))
+ (home-page "https://github.com/oantolin/embark")
+ (synopsis "Emacs mini-buffer actions rooted in keymaps")
+ (description
+ "This package provides a sort of right-click contextual menu for Emacs
offering you relevant @emph{actions} to use on a @emph{target} determined by
the context.
@@ -10334,7 +10335,7 @@ get offered actions like deleting, copying, renaming, visiting in another
window, running a shell command on the file, etc. For buffers the actions
include switching to or killing the buffer. For package names the actions
include installing, removing or visiting the homepage.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-prescient
(package