summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2022-12-21 06:48:21 -0800
committerLudovic Courtès <ludo@gnu.org>2023-01-26 11:11:19 +0100
commit59a714057f8d44ecf93e960d3b1400b00531c889 (patch)
tree4881972230602cfa0c08562bfc87ac8b2dd8a829
parent359d33ee404a4e0de5890a6e44ceed5459c076c6 (diff)
downloadguix-patches-59a714057f8d44ecf93e960d3b1400b00531c889.tar
guix-patches-59a714057f8d44ecf93e960d3b1400b00531c889.tar.gz
gnu: Add python-pysimplesoap.
* gnu/packages/python-web.scm (python-pysimplesoap): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7daa1b636c..ac0fb6f8a7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7987,6 +7987,27 @@ resources using Web Application Description Language (WADL) files as guides.")
@end itemize")
(license license:expat)))
+(define-public python-pysimplesoap
+ (package
+ (name "python-pysimplesoap")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PySimpleSOAP" version))
+ (sha256
+ (base32
+ "1qb7dn8m1cjwzql7vqj9i1hsscb7nyhimmlp45jrpzxds38g9fxi"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:tests? #f)) ;tests fail due to attempted web access
+ (home-page "https://github.com/pysimplesoap/pysimplesoap")
+ (synopsis "Simple and lightweight SOAP library for Python")
+ (description
+ "This package provides a simple and lightweight Python SOAP library for
+client and server webservices interfaces, aimed to be as small and easy as
+possible, supporting most common functionality.")
+ (license license:lgpl3+)))
+
(define-public python-http-client
(package
(name "python-http-client")