summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Tai <atai@atai.org>2023-02-22 22:37:36 -0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-03-05 08:17:57 +0100
commit7fc415aba9444fff0f840892cf01f588d67e698c (patch)
tree5163b4af49df062a4f805282a1fa5ed3707b60e9
parentf9f9efc467ce8678e815d6aed848026b4ffdfbc9 (diff)
downloadguix-patches-7fc415aba9444fff0f840892cf01f588d67e698c.tar
guix-patches-7fc415aba9444fff0f840892cf01f588d67e698c.tar.gz
gnu: meld: Use new package style.
* gnu/packages/patchutils.scm (meld)[arguments]: Convert to list of G-Expressions. <#:phases>: Drop trailing #t. [inputs, native-inputs]: Drop labels. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/patchutils.scm74
1 files changed, 37 insertions, 37 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index fd1ba83b3c..05a9a62dbf 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -232,50 +232,50 @@ GiB).")
(base32 "03f4j27amyi28flkks8i9bhqzd6xhm6d3c6jzxc57rzniv4hgh9z"))))
(build-system meson-build-system)
(native-inputs
- `(("desktop-file-utils" ,desktop-file-utils)
- ("intltool" ,intltool)
- ("itstool" ,itstool)
- ("xmllint" ,libxml2)
- ("glib-compile-schemas" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list desktop-file-utils
+ intltool
+ itstool
+ libxml2
+ `(,glib "bin") ; for glib-compile-schemas
+ gobject-introspection
+ pkg-config
+ python))
(inputs
- `(("bash-minimal" ,bash-minimal)
- ("python" ,python)
- ("python-cairo" ,python-pycairo)
- ("python-gobject" ,python-pygobject)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtksourceview" ,gtksourceview-4)))
+ (list bash-minimal
+ python
+ python-pycairo
+ python-pygobject
+ gsettings-desktop-schemas
+ gtksourceview-4))
(propagated-inputs
(list dconf))
(arguments
- `(#:glib-or-gtk? #t
- #:imported-modules (,@%meson-build-system-modules
+ (list
+ #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
(guix build python-build-system))
- #:modules ((guix build meson-build-system)
+ #:modules '((guix build meson-build-system)
((guix build python-build-system) #:prefix python:)
(guix build utils))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-gtk-update-icon-cache
- ;; Don't create 'icon-theme.cache'.
- (lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") (which "true")))))
- (add-after 'install 'copy-styles
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((styles "/share/gtksourceview-4/styles"))
- (copy-recursively
- (string-append (assoc-ref inputs "gtksourceview") styles)
- (string-append (assoc-ref outputs "out") styles))
- #t)))
- (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (wrap-program (search-input-file outputs "bin/meld")
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
- ,(python:site-packages inputs outputs)))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") (which "true")))))
+ (add-after 'install 'copy-styles
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((styles "/share/gtksourceview-4/styles"))
+ (copy-recursively
+ (string-append (assoc-ref inputs "gtksourceview") styles)
+ (string-append (assoc-ref outputs "out") styles)))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/meld")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
(home-page "https://meldmerge.org/")
(synopsis "Compare files, directories and working copies")
(description "Meld is a visual diff and merge tool targeted at